summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Audron <audron@cocaine.farm>2020-06-15 15:27:54 +0200
committerStefan Strogin <steils@gentoo.org>2020-06-16 13:35:57 +0300
commit3514eef209b0c22c422ef3ea015f75f188f039ee (patch)
treed2d1fd38f9dfb6c170b0926620442c753823afe2 /media-libs
parentdev-python/tld: 0.12.2 bump (diff)
downloadgentoo-3514eef209b0c22c422ef3ea015f75f188f039ee.tar.gz
gentoo-3514eef209b0c22c422ef3ea015f75f188f039ee.tar.bz2
gentoo-3514eef209b0c22c422ef3ea015f75f188f039ee.zip
media-libs/glfw: version bump to 3.3.2
Signed-off-by: Max Audron <audron@cocaine.farm> Add x11-libs/libXi to BDEPEND because glfw needs XInput2.h for compilation, but does not link against libXi.so. Closes: https://bugs.gentoo.org/722186 Closes: https://github.com/gentoo/gentoo/pull/16257 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/glfw/Manifest1
-rw-r--r--media-libs/glfw/glfw-3.3.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/glfw/Manifest b/media-libs/glfw/Manifest
index c6bef6eab775..5fb322eae04d 100644
--- a/media-libs/glfw/Manifest
+++ b/media-libs/glfw/Manifest
@@ -1,2 +1,3 @@
DIST glfw-3.2.1.tar.gz 472450 BLAKE2B abffe6580dee968baa23f8f4f38af164f7479fe0bf3c4d64cc6386b1450aee4a8e8de5f963faecd536e2bbbc925da7ac1dcc16f219984758950263e6b6d022e1 SHA512 c7921f993b9a99b3b9421fefadb039cd475c42d85f5b5a35d7c5401c70491349bb885a02fd31e527de06a8b40d9d49a1fdb92c964e13c04ae092c6b98eb491dc
DIST glfw-3.3.1.tar.gz 760014 BLAKE2B 72d23a612157b2083dc6950ff7a2531490d1440f24008fca39646860ea7f9e61eedc5d3c96edb024a125f2e9a1ef65780b4a672aa001bcbc6f41d908e904f966 SHA512 f9376002314eae5518ca63738cf1558433007dbf628fb6093a6f54c330f72d85e0ac30049877c50bc99f029e3eb6f69e69508f412d1ec9bdde0ac721dbbeba1e
+DIST glfw-3.3.2.tar.gz 759972 BLAKE2B a246681d580dd569a045b76db71c18f8dbfacb8483c2d825aa68094d655468d093c52ba3770b2b5d566de62149a775001f5acd7c7539a8235c43e3e9ab58df28 SHA512 f5af749d33b5b900ccf07988ad0bf51bd766a18e4cf2bc2a76020c88e98a2528ff1b965224184fe0d290cfe34b1af1e6f633600660d81194fe354078e2f35c56
diff --git a/media-libs/glfw/glfw-3.3.2.ebuild b/media-libs/glfw/glfw-3.3.2.ebuild
new file mode 100644
index 000000000000..344e650b9d62
--- /dev/null
+++ b/media-libs/glfw/glfw-3.3.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="https://www.glfw.org/"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~x86"
+IUSE="wayland"
+
+RDEPEND="
+ x11-libs/libxkbcommon
+ !wayland? (
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ )
+ wayland? (
+ dev-libs/wayland
+ media-libs/mesa[egl,wayland]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ wayland? ( dev-libs/wayland-protocols )
+"
+BDEPEND="
+ !wayland? ( x11-libs/libXi )
+ wayland? ( kde-frameworks/extra-cmake-modules )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLFW_BUILD_EXAMPLES=no
+ -DGLFW_USE_WAYLAND="$(usex wayland)"
+ -DBUILD_SHARED_LIBS=1
+ )
+ cmake_src_configure
+}