summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-10 09:59:37 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-12 12:05:59 +0300
commit36a75c6f81fb32e9b84d029f1977a8e22312b4dc (patch)
treef015e12c186f8b2d695dfd96c347ea4128dc1519 /media-libs
parentmedia-libs/libheif: new maintainer (diff)
downloadgentoo-36a75c6f81fb32e9b84d029f1977a8e22312b4dc.tar.gz
gentoo-36a75c6f81fb32e9b84d029f1977a8e22312b4dc.tar.bz2
gentoo-36a75c6f81fb32e9b84d029f1977a8e22312b4dc.zip
media-libs/libheif: enable tests (again)
- go code is needed to run tests, add appropriate REQUIRED_USE entry - remove "$use_enable go" as go code seems to be enabled by default. Passing --enable-go disrupts the build system and strangely prevents us to run tests (likely an upstream bug) Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libheif/libheif-1.7.0-r1.ebuild9
-rw-r--r--media-libs/libheif/libheif-1.7.0-r2.ebuild9
-rw-r--r--media-libs/libheif/libheif-1.9.1.ebuild9
-rw-r--r--media-libs/libheif/libheif-9999.ebuild9
4 files changed, 32 insertions, 4 deletions
diff --git a/media-libs/libheif/libheif-1.7.0-r1.ebuild b/media-libs/libheif/libheif-1.7.0-r1.ebuild
index 389834d35862..6eb48cf9b41b 100644
--- a/media-libs/libheif/libheif-1.7.0-r1.ebuild
+++ b/media-libs/libheif/libheif-1.7.0-r1.ebuild
@@ -19,6 +19,8 @@ HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
SLOT="0/1.7"
IUSE="gdk-pixbuf go static-libs test +threads"
+REQUIRED_USE="test? ( go )"
+
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-lang/go )"
@@ -49,7 +51,7 @@ src_prepare() {
multilib_src_configure() {
local econf_args=(
- $(multilib_is_native_abi && use_enable go || echo --disable-go)
+ $(multilib_is_native_abi && use go || echo --disable-go)
$(use_enable gdk-pixbuf)
$(use_enable static-libs static)
$(use_enable threads multithreading)
@@ -57,6 +59,11 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" econf "${econf_args[@]}"
}
+multilib_src_test() {
+ default
+ emake -C go test
+}
+
multilib_src_install_all() {
find "${ED}" -name '*.la' -delete || die
}
diff --git a/media-libs/libheif/libheif-1.7.0-r2.ebuild b/media-libs/libheif/libheif-1.7.0-r2.ebuild
index e54b807b2dfa..0e817601bd62 100644
--- a/media-libs/libheif/libheif-1.7.0-r2.ebuild
+++ b/media-libs/libheif/libheif-1.7.0-r2.ebuild
@@ -19,6 +19,8 @@ HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
SLOT="0/1.7"
IUSE="gdk-pixbuf go static-libs test +threads"
+REQUIRED_USE="test? ( go )"
+
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-lang/go )"
@@ -50,7 +52,7 @@ src_prepare() {
multilib_src_configure() {
local econf_args=(
- $(multilib_is_native_abi && use_enable go || echo --disable-go)
+ $(multilib_is_native_abi && use go || echo --disable-go)
$(use_enable gdk-pixbuf)
$(use_enable static-libs static)
$(use_enable threads multithreading)
@@ -58,6 +60,11 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" econf "${econf_args[@]}"
}
+multilib_src_test() {
+ default
+ emake -C go test
+}
+
multilib_src_install_all() {
find "${ED}" -name '*.la' -delete || die
}
diff --git a/media-libs/libheif/libheif-1.9.1.ebuild b/media-libs/libheif/libheif-1.9.1.ebuild
index bccbc8c86622..ccfee4058de5 100644
--- a/media-libs/libheif/libheif-1.9.1.ebuild
+++ b/media-libs/libheif/libheif-1.9.1.ebuild
@@ -19,6 +19,8 @@ HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
SLOT="0/1.9"
IUSE="gdk-pixbuf go static-libs test +threads"
+REQUIRED_USE="test? ( go )"
+
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-lang/go )"
@@ -47,7 +49,7 @@ src_prepare() {
multilib_src_configure() {
local econf_args=(
- $(multilib_is_native_abi && use_enable go || echo --disable-go)
+ $(multilib_is_native_abi && use go || echo --disable-go)
$(use_enable gdk-pixbuf)
$(use_enable static-libs static)
$(use_enable threads multithreading)
@@ -55,6 +57,11 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" econf "${econf_args[@]}"
}
+multilib_src_test() {
+ default
+ emake -C go test
+}
+
multilib_src_install_all() {
find "${ED}" -name '*.la' -delete || die
}
diff --git a/media-libs/libheif/libheif-9999.ebuild b/media-libs/libheif/libheif-9999.ebuild
index bccbc8c86622..ccfee4058de5 100644
--- a/media-libs/libheif/libheif-9999.ebuild
+++ b/media-libs/libheif/libheif-9999.ebuild
@@ -19,6 +19,8 @@ HOMEPAGE="https://github.com/strukturag/libheif"
LICENSE="GPL-3"
SLOT="0/1.9"
IUSE="gdk-pixbuf go static-libs test +threads"
+REQUIRED_USE="test? ( go )"
+
RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-lang/go )"
@@ -47,7 +49,7 @@ src_prepare() {
multilib_src_configure() {
local econf_args=(
- $(multilib_is_native_abi && use_enable go || echo --disable-go)
+ $(multilib_is_native_abi && use go || echo --disable-go)
$(use_enable gdk-pixbuf)
$(use_enable static-libs static)
$(use_enable threads multithreading)
@@ -55,6 +57,11 @@ multilib_src_configure() {
ECONF_SOURCE="${S}" econf "${econf_args[@]}"
}
+multilib_src_test() {
+ default
+ emake -C go test
+}
+
multilib_src_install_all() {
find "${ED}" -name '*.la' -delete || die
}