summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-26 19:00:52 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-26 19:20:49 +0100
commit36e0111df8a1866c5da4604f7a377e995c343142 (patch)
treea7ef838a276622414186f1225b40b6f110787ab1 /media-libs
parentmedia-plugins/gst-plugins-x264: version bump to 1.6.2 (diff)
downloadgentoo-36e0111df8a1866c5da4604f7a377e995c343142.tar.gz
gentoo-36e0111df8a1866c5da4604f7a377e995c343142.tar.bz2
gentoo-36e0111df8a1866c5da4604f7a377e995c343142.zip
media-libs/gst-rtsp-server: version bump to 1.6.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-rtsp-server/Manifest1
-rw-r--r--media-libs/gst-rtsp-server/gst-rtsp-server-1.6.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/media-libs/gst-rtsp-server/Manifest b/media-libs/gst-rtsp-server/Manifest
index a6bfbca1e916..6b4e8b886d7d 100644
--- a/media-libs/gst-rtsp-server/Manifest
+++ b/media-libs/gst-rtsp-server/Manifest
@@ -1,2 +1,3 @@
DIST gst-rtsp-0.10.8.tar.bz2 567670 SHA256 9915887cf8515bda87462c69738646afb715b597613edc7340477ccab63a6617 SHA512 c5020cffa9334b7d9c6b9dbe6f32bd4580eeee1c67689269d232e954ef9d96d8b988e3fb19da89701eae26419df0bf6de5796f7780cfbedda4c07154b1c1ebd7 WHIRLPOOL 6bd260edaef5ab003ef7176d84c46d5a94d365af51226108af9ab845d6e5910d90c721d5fd87e7fe93b141a82e5114b4c674a1d2500ef57302bf845c87f5463c
DIST gst-rtsp-server-1.4.5.tar.xz 530724 SHA256 3089254bd31b7c1f1cf2c034a3b3551f92878f9e3cab65cef3a901a04c0f1d37 SHA512 0f7bbad94416de73abffd76f88fa051b6db4e5250486669b29b101d06a3629ccef886f2048d51d1e3b78c22393eaa86a1f44c696b25ffabc19a1c37c3e442a35 WHIRLPOOL 0a82942e3172a5d6f7699e73c41ab6cfd5c85c52153058fc38673dd347df5f67fa26229273cf29a6ef841c85ddf3ae3f37c0d5db073978c7f9d5546db9b7ce39
+DIST gst-rtsp-server-1.6.2.tar.xz 560824 SHA256 0f51f9879556c0950203c766b09a1b62f1f25b17f9a7d516e01b13ecf93c8858 SHA512 853a26cde765f029c1d357092684a2c0b187c213e0877567b17f45727e179e110fd55484134bfee0dfd32b5af8fa8443c5cafac0aa6d445166fe3d12aa331354 WHIRLPOOL fba57cdb95926312f2e9d3db495ecffdd46962c758aafb606d18c900007561e8da7233da2939100ba7fd03d4d4c4605c72511a2cc26408e09aefd83f2d59e6ae
diff --git a/media-libs/gst-rtsp-server/gst-rtsp-server-1.6.2.ebuild b/media-libs/gst-rtsp-server/gst-rtsp-server-1.6.2.ebuild
new file mode 100644
index 000000000000..71a6596d6952
--- /dev/null
+++ b/media-libs/gst-rtsp-server/gst-rtsp-server-1.6.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gstreamer
+
+DESCRIPTION="A GStreamer based RTSP server"
+HOMEPAGE="http://people.freedesktop.org/~wtay/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +introspection static-libs test"
+
+# FIXME: check should depend on USE=test but check is losy
+# configure says good and bad are required by macros forces them to be optional
+# they are only used in unittests anyway.
+RDEPEND="
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/check-0.9.2
+ >=dev-util/gtk-doc-am-1.12
+ virtual/pkgconfig
+ test? (
+ >=media-libs/gst-plugins-bad-${PV}:${SLOT}[introspection?,${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-good-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ )
+"
+
+# Due to gstreamer src_configure
+QA_CONFIGURE_OPTIONS="--enable-nls"
+
+multilib_src_configure() {
+ # debug: only adds -g to CFLAGS
+ # docbook: nothing behind that switch
+ # libcgroup is automagic and only used in examples
+ gstreamer_multilib_src_configure \
+ --disable-examples \
+ --disable-docbook \
+ --disable-gtk-doc \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ LIBCGROUP_LIBS= \
+ LIBCGROUP_FLAGS=
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi ; then
+ ln -s "${S}"/docs/libs/${d}/html docs/libs/${d}/html || die
+ fi
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+ # Handle broken upstream modifications to defaults of gtk-doc
+ emake install -C docs/libs DESTDIR="${D}"
+ prune_libtool_files
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}