summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 17:47:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 17:48:03 +0100
commit389efddf0c61a8f935afd48cc84f27801789605f (patch)
tree68462af3777e5968062c072a351f8a8783ebca8b /media-libs
parentdev-python/wand: remove old (diff)
downloadgentoo-389efddf0c61a8f935afd48cc84f27801789605f.tar.gz
gentoo-389efddf0c61a8f935afd48cc84f27801789605f.tar.bz2
gentoo-389efddf0c61a8f935afd48cc84f27801789605f.zip
media-libs/vigra: Sync cmake.eclass and python3_9 to live ebuild
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/vigra/vigra-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/media-libs/vigra/vigra-9999.ebuild b/media-libs/vigra/vigra-9999.ebuild
index c445f2e401cf..9ffac6b73b01 100644
--- a/media-libs/vigra/vigra-9999.ebuild
+++ b/media-libs/vigra/vigra-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
PYTHON_REQ_USE="threads(+),xml"
-inherit cmake-utils python-r1
+inherit cmake python-r1
DESCRIPTION="C++ computer vision library emphasizing customizable algorithms and structures"
HOMEPAGE="https://ukoethe.github.io/vigra/"
@@ -83,7 +83,7 @@ src_prepare() {
fi
}
- cmake-utils_src_prepare
+ cmake_src_prepare
if [[ ${PV} != *9999 ]]; then
rm -r doc || die "failed to remove shipped docs"
@@ -101,7 +101,7 @@ src_prepare() {
if ! use test; then
cmake_comment_add_subdirectory test
- sed -e "/ADD_SUBDIRECTORY.*test/s/^/#DONT /" -i vigranumpy/CMakeLists.txt || die
+ cmake_run_in vigranumpy cmake_comment_add_subdirectory test
fi
}
@@ -116,7 +116,7 @@ src_configure() {
-DWITH_VALGRIND=$(usex valgrind)
-DWITH_VIGRANUMPY=$(usex python)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
if use python; then
@@ -131,7 +131,7 @@ src_configure() {
src_compile() {
local VIGRA_BUILD_DIR
vigra_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
VIGRA_BUILD_DIR="${BUILD_DIR}"
}
if use python; then
@@ -150,17 +150,17 @@ src_compile() {
src_install() {
if use python; then
- python_foreach_impl cmake-utils_src_install
+ python_foreach_impl cmake_src_install
python_optimize
else
- cmake-utils_src_install
+ cmake_src_install
fi
}
src_test() {
# perhaps disable tests (see #390447)
vigra_test() {
- PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake-utils_src_test
+ PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake_src_test
}
if use python; then
python_foreach_impl vigra_test