summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-02 01:40:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-02 01:43:06 +0200
commit3cc1c5be1081952771c7f09469994ab6f25ed79e (patch)
treed2a23f32de0cf7f8e370d310398c18e69c977a0a /media-libs
parentmedia-libs/libfreehand: EAPI-7 bump, consolidate live build switch (diff)
downloadgentoo-3cc1c5be1081952771c7f09469994ab6f25ed79e.tar.gz
gentoo-3cc1c5be1081952771c7f09469994ab6f25ed79e.tar.bz2
gentoo-3cc1c5be1081952771c7f09469994ab6f25ed79e.zip
media-libs/libpagemaker: EAPI-7 bump, consolidate live build switch
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libpagemaker/libpagemaker-9999.ebuild38
1 files changed, 21 insertions, 17 deletions
diff --git a/media-libs/libpagemaker/libpagemaker-9999.ebuild b/media-libs/libpagemaker/libpagemaker-9999.ebuild
index ce90d99852b3..35b64943085a 100644
--- a/media-libs/libpagemaker/libpagemaker-9999.ebuild
+++ b/media-libs/libpagemaker/libpagemaker-9999.ebuild
@@ -1,44 +1,48 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="git://gerrit.libreoffice.org/${PN}.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
-
-DESCRIPTION="C++ Library that parses the file format of Aldus/Adobe PageMaker documents."
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="git://gerrit.libreoffice.org/${PN}.git"
+ inherit autotools git-r3
+else
+ SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+DESCRIPTION="C++ Library that parses the file format of Aldus/Adobe PageMaker documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
LICENSE="MPL-2.0"
SLOT="0"
-
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="debug doc tools"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
RDEPEND="
dev-libs/librevenge
"
DEPEND="${RDEPEND}
dev-libs/boost
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
"
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
- econf \
- --disable-werror \
- $(use_with doc docs) \
+ local myeconfargs=(
+ --disable-werror
+ $(use_with doc docs)
$(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}