summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2015-10-01 14:14:28 -0700
committerMatt Turner <mattst88@gentoo.org>2015-10-01 17:34:06 -0700
commit4ad28e37ede07e2dd3fa48dcae60684940e9f002 (patch)
treeca494b85cdfa1dc2279805cb721aefe06e05e4c5 /media-libs
parentmedia-libs/mesa: Fix pax_kernel USE flag. (diff)
downloadgentoo-4ad28e37ede07e2dd3fa48dcae60684940e9f002.tar.gz
gentoo-4ad28e37ede07e2dd3fa48dcae60684940e9f002.tar.bz2
gentoo-4ad28e37ede07e2dd3fa48dcae60684940e9f002.zip
media-libs/mesa: Use upstream --enable-glx-read-only-text.
We can now avoid eautoreconf!
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-11.0.2.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/media-libs/mesa/mesa-11.0.2.ebuild b/media-libs/mesa/mesa-11.0.2.ebuild
index af7553fe3fda..38d52d0732cd 100644
--- a/media-libs/mesa/mesa-11.0.2.ebuild
+++ b/media-libs/mesa/mesa-11.0.2.ebuild
@@ -6,7 +6,7 @@ EAPI=5
EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
-if [[ ${PV} = 9999* ]]; then
+if [[ ${PV} = 9999 ]]; then
GIT_ECLASS="git-r3"
EXPERIMENTAL="true"
fi
@@ -23,15 +23,16 @@ FOLDER="${PV/_rc*/}"
DESCRIPTION="OpenGL-like graphic library for Linux"
HOMEPAGE="http://mesa3d.sourceforge.net/"
-if [[ $PV == 9999* ]]; then
+if [[ $PV == 9999 ]]; then
SRC_URI=""
+ KEYWORDS=""
else
SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${FOLDER}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
RESTRICT="!bindist? ( bindist )"
INTEL_CARDS="i915 i965 ilo intel"
@@ -110,7 +111,7 @@ RDEPEND="
opencl? (
app-eselect/eselect-opencl
dev-libs/libclc
- !kernel_FreeBSD? ( || (
+ !kernel_FreeBSD? ( || (
>=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
>=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
) )
@@ -158,7 +159,7 @@ DEPEND="${RDEPEND}
>=x11-proto/xf86driproto-2.1.1-r1:=[${MULTILIB_USEDEP}]
>=x11-proto/xf86vidmodeproto-2.3.1-r1:=[${MULTILIB_USEDEP}]
"
-[[ ${PV} == "9999" ]] && DEPEND+="
+[[ ${PV} == 9999 ]] && DEPEND+="
sys-devel/bison
sys-devel/flex
${PYTHON_DEPS}
@@ -190,10 +191,7 @@ pkg_setup() {
}
src_prepare() {
- # fix for hardened pax_kernel, bug 240956
- [[ ${PV} != 9999* ]] && epatch "${FILESDIR}"/glx_ro_text_segm.patch
-
- eautoreconf
+ [[ ${PV} == 9999 ]] && eautoreconf
}
multilib_src_configure() {
@@ -267,11 +265,9 @@ multilib_src_configure() {
fi
fi
- # x86 hardened pax_kernel needs glx-rts, bug 240956
- if use pax_kernel; then
- myconf+="
- $(use_enable x86 glx-rts)
- "
+ # x86 hardened pax_kernel needs glx-read-only-text, bug 240956
+ if [[ ${ABI} == x86 ]]; then
+ myconf+="$(use_enable pax_kernel glx-read-only-text)"
fi
# on abi_x86_32 hardened we need to have asm disable