summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-26 19:54:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-26 19:54:05 +0200
commit52d0062d921ce39b3459fdfc793f703ef3761bcd (patch)
tree7090c6ce7e1546c9594ca66a6f29767ccda049ad /media-libs
parentdev-libs/libcdio-paranoia: Revbump to make use of dev-libs/libcdio sub-slot. (diff)
downloadgentoo-52d0062d921ce39b3459fdfc793f703ef3761bcd.tar.gz
gentoo-52d0062d921ce39b3459fdfc793f703ef3761bcd.tar.bz2
gentoo-52d0062d921ce39b3459fdfc793f703ef3761bcd.zip
media-libs/harfbuzz: Bump to version 1.3.3
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-1.3.3.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index ec9264eae578..7e30b6c16aea 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -3,3 +3,4 @@ DIST harfbuzz-1.1.3.tar.bz2 1294579 SHA256 d93d7cb7979c32672e902fdfa884599e63f07
DIST harfbuzz-1.2.7.tar.bz2 1345389 SHA256 bba0600ae08b84384e6d2d7175bea10b5fc246c4583dc841498d01894d479026 SHA512 e1edfa0bf4936f7d47e5622547429b7f573710ac0c4fc023a7b00e1dceca8aa7f02800166eea0c883ae44d2886c50416d61791a8a8240ddaab9f4e389dadfff2 WHIRLPOOL 2ffcdb29b2a0506afb99e337c426c2e71cbc9ebf75add0ad25367fef6162984109260d6434fd1bf4fa9a8faba520eab1d5b1059286cd0d6d8a602dbf13d9181e
DIST harfbuzz-1.3.1.tar.bz2 1358437 SHA256 a242206dd119d5e6cc1b2253c116abbae03f9d930cb60b515fb0d248decf89a1 SHA512 7c2dbd1cc3c77646fd7627c4db9ac1a5781fb4babe8a92b276b2f2170f82d7075632253c7498c27735c5aa7331ee22d41e24c3a8cfa07adc2461ece1e36334b9 WHIRLPOOL 764b3f83d99d34dd73b989f57a3afdf0ef94de5a4b287717f4148c4d28976c1311b9c6bfbcfed612e53580c11c2228f0e3011bd689e3fa86b3a12185acd5cba1
DIST harfbuzz-1.3.2.tar.bz2 1357986 SHA256 8543a6372f08c5987c632dfaa86210c7edb3f43fbacd96095c609bc3539ce027 SHA512 19f846ee75d8a2d94da2a2b489fa8e54a5120599f998e451187f6695aa3931b28c491bbc0837892eaaebbd1da3441effe01f5f2470454f83cfa6a7c510ebcb32 WHIRLPOOL 507aa5d8f8517ef16d02f052f305b6566c5611c89b7cef904ddd577cc047acdc0b42f9fa5da10eccb56f884d5c20854d0cb4e2cb79ee133f728be7999ad961a5
+DIST harfbuzz-1.3.3.tar.bz2 1402836 SHA256 2620987115a4122b47321610dccbcc18f7f121115fd7b88dc8a695c8b66cb3c9 SHA512 d9759f849b892db534da163074b21d444c1558fed31de3b025ff6a8d14af180bd758735fcb9c58ca579a585f168644b5397a85a3767c73c13b2e343a63cd59ed WHIRLPOOL 4d6a90a6dfad81889e833201719c15e08cf862bdfaf64fd6ecd6db1f86e5af66662c3fcae0a244cc636ea3b3d4bf14dd85b363fa7426a5650aa601a8901ec4ab
diff --git a/media-libs/harfbuzz/harfbuzz-1.3.3.ebuild b/media-libs/harfbuzz/harfbuzz-1.3.3.ebuild
new file mode 100644
index 000000000000..03f88f153249
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-1.3.3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils libtool multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+[[ ${PV} == 9999 ]] || SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+
+IUSE="+cairo fontconfig +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+[[ ${PV} = 9999 ]] && DEPEND="${DEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # failing test, https://bugs.freedesktop.org/show_bug.cgi?id=89190
+ sed -e 's#tests/arabic-fallback-shaping.tests##' -i test/shaping/Makefile.in || die "sed failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ econf \
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with cairo) \
+ $(use_with fontconfig) \
+ $(use_with glib) \
+ $(use_with introspection gobject) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(multilib_native_use_enable introspection) \
+ $(use_with truetype freetype)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}