summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-27 20:34:29 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-27 20:37:25 +0100
commit53123145d790b74aad2a4a8bb3cbfb7c64c1040f (patch)
treee99037cf5bfc8f8fcdbae1a96bc3a3a72e3ba19c /media-libs
parentpackage.mask: Extend sys-devel/gcc mask to <5.4 (diff)
downloadgentoo-53123145d790b74aad2a4a8bb3cbfb7c64c1040f.tar.gz
gentoo-53123145d790b74aad2a4a8bb3cbfb7c64c1040f.tar.bz2
gentoo-53123145d790b74aad2a4a8bb3cbfb7c64c1040f.zip
media-libs/mesa: Bind LLVM deps to <4 (= slot 0) in 17.1.10
Closes: https://bugs.gentoo.org/640650 Closes: https://bugs.gentoo.org/641908
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-17.1.10.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-libs/mesa/mesa-17.1.10.ebuild b/media-libs/mesa/mesa-17.1.10.ebuild
index 935abcb79a17..1f6c50859094 100644
--- a/media-libs/mesa/mesa-17.1.10.ebuild
+++ b/media-libs/mesa/mesa-17.1.10.ebuild
@@ -98,7 +98,7 @@ RDEPEND="
llvm? (
video_cards_radeonsi? (
virtual/libelf:0=[${MULTILIB_USEDEP}]
- vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
+ vulkan? ( >=sys-devel/llvm-3.9.0:0=[${MULTILIB_USEDEP}] )
)
video_cards_r600? (
virtual/libelf:0=[${MULTILIB_USEDEP}]
@@ -106,7 +106,7 @@ RDEPEND="
video_cards_radeon? (
virtual/libelf:0=[${MULTILIB_USEDEP}]
)
- >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
+ >=sys-devel/llvm-3.6.0:0=[${MULTILIB_USEDEP}]
)
opencl? (
app-eselect/eselect-opencl
@@ -144,13 +144,13 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}
llvm? (
video_cards_radeonsi? ( || (
- sys-devel/llvm[llvm_targets_AMDGPU]
- sys-devel/llvm[video_cards_radeon]
+ sys-devel/llvm:0[llvm_targets_AMDGPU]
+ sys-devel/llvm:0[video_cards_radeon]
) )
)
opencl? (
- >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
- >=sys-devel/clang-3.6.0:=[${MULTILIB_USEDEP}]
+ >=sys-devel/llvm-3.6.0:0=[${MULTILIB_USEDEP}]
+ >=sys-devel/clang-3.6.0:0=[${MULTILIB_USEDEP}]
>=sys-devel/gcc-4.6
)
sys-devel/gettext
@@ -188,7 +188,7 @@ x86? (
pkg_setup() {
# warning message for bug 459306
- if use llvm && has_version sys-devel/llvm[!debug=]; then
+ if use llvm && has_version "sys-devel/llvm:0[!debug=]"; then
ewarn "Mismatch between debug USE flags in media-libs/mesa and sys-devel/llvm"
ewarn "detected! This can cause problems. For details, see bug 459306."
fi