summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 00:29:37 +0000
committerSam James <sam@gentoo.org>2021-02-27 01:00:10 +0000
commit57a850cbaa6950f3c274f0b3ac8822ed1a080714 (patch)
tree978908e2929b7ca6ef61afedb43c9d37ce4b7b01 /media-libs
parentdev-util/ragel: port 6.10 to EAPI 7 (diff)
downloadgentoo-57a850cbaa6950f3c274f0b3ac8822ed1a080714.tar.gz
gentoo-57a850cbaa6950f3c274f0b3ac8822ed1a080714.tar.bz2
gentoo-57a850cbaa6950f3c274f0b3ac8822ed1a080714.zip
media-libs/jbig2enc: port to EAPI 7
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild b/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
index b1e25014dafb..f6949b5e887e 100644
--- a/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
+++ b/media-libs/jbig2enc/jbig2enc-0.28-r1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils
+inherit autotools
DESCRIPTION="JBIG2 Encoder and libs"
HOMEPAGE="https://github.com/agl/jbig2enc"
@@ -13,19 +12,29 @@ SRC_URI="https://github.com/agl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86 ~ppc-macos"
-
-IUSE="gif jpeg png static-libs tiff webp"
+IUSE="gif jpeg png tiff webp"
RDEPEND="media-libs/leptonica[gif?,jpeg?,png?,tiff?,webp?]"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${P}-leptonica-1.70.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-leptonica-1.70.patch"
+)
src_prepare() {
+ default
+
# remove -Werror
sed -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac || die 'sed on configure.ac failed'
# prevent static linking and QA notice about insecure RUNPATHs
sed -i -e '/jbig2_LDFLAGS/d' src/Makefile.am || die 'sed on src/Makefile.am failed'
- autotools-utils_src_prepare
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+ find "${ED}" -name '*.a' -delete || die
}