summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-04-08 23:47:08 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-04-08 23:47:36 +0200
commit587259e86b651310073ce82055be24ac327abdc8 (patch)
tree1a6e995f8e9b577407d3d9ac363646a8e81a4fe8 /media-libs
parentnet-libs/nDPI: use HTTPS. (diff)
downloadgentoo-587259e86b651310073ce82055be24ac327abdc8.tar.gz
gentoo-587259e86b651310073ce82055be24ac327abdc8.tar.bz2
gentoo-587259e86b651310073ce82055be24ac327abdc8.zip
media-libs/vigra: No revbump for build fixes needed
Backporting to stable to avoid rebuilds Bug: https://bugs.gentoo.org/664720 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/vigra/vigra-1.11.1.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/media-libs/vigra/vigra-1.11.1.ebuild b/media-libs/vigra/vigra-1.11.1.ebuild
index 44a25f14450a..b2db9b985bc5 100644
--- a/media-libs/vigra/vigra-1.11.1.ebuild
+++ b/media-libs/vigra/vigra-1.11.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,11 +11,17 @@ inherit cmake-utils python-r1
DESCRIPTION="C++ computer vision library emphasizing customizable algorithms and structures"
HOMEPAGE="https://ukoethe.github.io/vigra/"
-SRC_URI="https://github.com/ukoethe/vigra/releases/download/Version-${MY_V}/${MY_P}.tar.gz"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ukoethe/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ukoethe/${PN}/releases/download/Version-${MY_V}/${MY_P}.tar.gz"
+ KEYWORDS="amd64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="doc +fftw +hdf5 +jpeg mpi openexr +png +python test +tiff valgrind"
# runtime dependency on python:2.7 is required by the vigra-config script
@@ -48,6 +54,10 @@ RESTRICT="test"
DOCS=( README.md )
+PATCHES=(
+ "${FILESDIR}/${P}-fix-incorrect-template-parameter-type.patch"
+)
+
pkg_setup() {
use python && python_setup
}