summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-10-25 09:46:53 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-10-25 09:47:07 +0200
commit61384a6550069e351d39e278a376cac4a1b9900e (patch)
tree2d2729b6f4e61d3ff8ecb51cdb3978717c9da7ee /media-libs
parentmedia-libs/sdl2-image: Bump to version 2.0.2 (diff)
downloadgentoo-61384a6550069e351d39e278a376cac4a1b9900e.tar.gz
gentoo-61384a6550069e351d39e278a376cac4a1b9900e.tar.bz2
gentoo-61384a6550069e351d39e278a376cac4a1b9900e.zip
media-libs/sdl2-mixer: Bump to version 2.0.2
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/sdl2-mixer/Manifest1
-rw-r--r--media-libs/sdl2-mixer/sdl2-mixer-2.0.2.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/media-libs/sdl2-mixer/Manifest b/media-libs/sdl2-mixer/Manifest
index da4e2fab677a..c1d892cfa056 100644
--- a/media-libs/sdl2-mixer/Manifest
+++ b/media-libs/sdl2-mixer/Manifest
@@ -1 +1,2 @@
DIST SDL2_mixer-2.0.1.tar.gz 10213891 SHA256 5a24f62a610249d744cbd8d28ee399d8905db7222bf3bdbc8a8b4a76e597695f SHA512 bdf2b4fc302f9c3b41d40bfdd5132081439e6021e915f191e478235b7b6565e7b4c43e1172d2055066ad505e2bc70876123c58f5a67218b207c829ee66a84b9d WHIRLPOOL b9ebeaad35ed92e8de111872d17ceefdc996ebbbb91f3b35fa9ab62573fae972e1a1626cc86141260c69af87a53a0880230ec399fe06fa3c5a98b20d82be8515
+DIST SDL2_mixer-2.0.2.tar.gz 9620763 SHA256 4e615e27efca4f439df9af6aa2c6de84150d17cbfd12174b54868c12f19c83bb SHA512 c40b5ac93933df1cc932e7afe796ad6765aafb24077601a23f98ac625a83341079ad903c164eafd022aff6011872e7a7956eebd8e3d3edad1bf5dc7eb9c306b7 WHIRLPOOL a7723fe6d0bd99022465491191e164d1bd7a8b81c13ae6e5217fafe649d75333f6a0e3bbc1a8f541cc48428319aaf88ac814a5704faf562570de1c2df45ae692
diff --git a/media-libs/sdl2-mixer/sdl2-mixer-2.0.2.ebuild b/media-libs/sdl2-mixer/sdl2-mixer-2.0.2.ebuild
new file mode 100644
index 000000000000..d818f3bf9bb1
--- /dev/null
+++ b/media-libs/sdl2-mixer/sdl2-mixer-2.0.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit ltprune multilib-minimal
+
+MY_P="SDL2_mixer-${PV}"
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac fluidsynth mad midi mikmod mod modplug mp3 playtools smpeg static-libs timidity tremor vorbis +wav"
+REQUIRED_USE="
+ midi? ( || ( timidity fluidsynth ) )
+ timidity? ( midi )
+ fluidsynth? ( midi )
+ mp3? ( || ( smpeg mad ) )
+ smpeg? ( mp3 )
+ mad? ( mp3 )
+ mod? ( || ( mikmod modplug ) )
+ mikmod? ( mod )
+ modplug? ( mod )
+ tremor? ( vorbis )
+ "
+
+RDEPEND=">=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]
+ flac? ( >=media-libs/flac-1.2.1-r5[${MULTILIB_USEDEP}] )
+ midi? (
+ fluidsynth? ( >=media-sound/fluidsynth-1.1.6-r1[${MULTILIB_USEDEP}] )
+ timidity? ( media-sound/timidity++ )
+ )
+ mp3? (
+ mad? ( >=media-libs/libmad-0.15.1b-r8[${MULTILIB_USEDEP}] )
+ smpeg? ( >=media-libs/smpeg2-2.0.0-r1[${MULTILIB_USEDEP}] )
+ )
+ mod? (
+ modplug? ( >=media-libs/libmodplug-0.8.8.4-r1[${MULTILIB_USEDEP}] )
+ mikmod? ( >=media-libs/libmikmod-3.3.6-r1[${MULTILIB_USEDEP}] )
+ )
+ vorbis? (
+ tremor? ( >=media-libs/tremor-0_pre20130223[${MULTILIB_USEDEP}] )
+ !tremor? (
+ >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}]
+ >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )
+ )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-sdltest
+ --enable-music-cmd
+ $(use_enable wav music-wave)
+ $(use_enable mod music-mod)
+ $(use_enable modplug music-mod-modplug)
+ --disable-music-mod-modplug-shared
+ $(use_enable mikmod music-mod-mikmod)
+ --disable-music-mod-mikmod-shared
+ $(use_enable midi music-midi)
+ $(use_enable timidity music-midi-timidity)
+ $(use_enable fluidsynth music-midi-fluidsynth)
+ --disable-music-midi-fluidsynth-shared
+ $(use_enable vorbis music-ogg)
+ $(use_enable tremor music-ogg-tremor)
+ --disable-music-ogg-shared
+ $(use_enable flac music-flac)
+ --disable-music-flac-shared
+ $(use_enable mp3 music-mp3)
+ $(use_enable smpeg music-mp3-smpeg)
+ --disable-music-mp3-smpeg-shared
+ --disable-smpegtest
+ $(use_enable mad music-mp3-mad-gpl)
+ LIBMIKMOD_CONFIG=${EPREFIX}/usr/bin/${CHOST}-libmikmod-config
+ )
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ if multilib_is_native_abi && use playtools ; then
+ emake DESTDIR="${D}" install-bin
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ # bug 412035
+ # https://bugs.gentoo.org/show_bug.cgi?id=412035
+ if use midi ; then
+ if use fluidsynth; then
+ ewarn "FluidSynth support requires you to set the SDL_SOUNDFONTS"
+ ewarn "environment variable to the location of a SoundFont file"
+ ewarn "unless the game or application happens to do this for you."
+
+ if use timidity; then
+ ewarn "Failing to do so will result in Timidity being used instead."
+ else
+ ewarn "Failing to do so will result in silence."
+ fi
+ fi
+ fi
+}