summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-07-02 15:01:39 -0600
committerTim Harder <radhermit@gentoo.org>2019-07-02 15:05:05 -0600
commit635b7b2811dafbc31ee6e968cc95bdb277519919 (patch)
tree2f8a6eaf624940982c3a6858cd13881383087d76 /media-libs
parentnet-analyzer/netdata: add support for dbengine (diff)
downloadgentoo-635b7b2811dafbc31ee6e968cc95bdb277519919.tar.gz
gentoo-635b7b2811dafbc31ee6e968cc95bdb277519919.tar.bz2
gentoo-635b7b2811dafbc31ee6e968cc95bdb277519919.zip
media-libs/cimg: version bump to 2.6.7
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cimg/Manifest1
-rw-r--r--media-libs/cimg/cimg-2.6.7.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/cimg/Manifest b/media-libs/cimg/Manifest
index 241d6e3f18ae..66ff0a3197f2 100644
--- a/media-libs/cimg/Manifest
+++ b/media-libs/cimg/Manifest
@@ -1,3 +1,4 @@
DIST cimg-2.4.3.tar.gz 11074736 BLAKE2B 097da7f5b214470247296265950061acefec19a169139c65eb12b27ed8e1256b97f77d28deb910bb444f38d396e36c204c761437e8991421422e840fd7505a95 SHA512 3409fde40780d293051914ce988193063139f1f805e5b0205e829234944c76b877a2723dd7c616158bbb58238baf653a03f34d55052103286d3ee28a33136d15
DIST cimg-2.4.5.tar.gz 11075045 BLAKE2B 6e9b9ccb5aa826526e9f9adbb964296a5f298772b696bad400a432bfd68e4b0048bbbb8591ac225393867aa2f00b708ea48c2858799522edcc2b021f3ba7fa7b SHA512 0a306ba4265a0e68d358e1ca54c597e80b43e72205de161d0971cd5837ca7d48322725d6ec129381e708a1d11fb5697884a5901ac753080fd8d8c08b80b28138
DIST cimg-2.6.5.tar.gz 11071672 BLAKE2B 61fa37c2f78e09d6aba0eb867c3797f86ed5a685a114dae779e439c76f4cc9768fada70affd2b14139c7fe7b2e79b61e653165abc47833e3a5cf857af0eb4ca4 SHA512 d8c1e10f702b47f6788fedf27681fe8e7ab3994c8018f96d4964694edda6acb1ca040244d7d1436a5381ec5a12e7a2b991ede6d9ea6d961ae6c4842feb2bf141
+DIST cimg-2.6.7.tar.gz 11072149 BLAKE2B 0695215eb57375ed216ab1b148bb09316af8f6e0191589e4a9a91b25355857a75d2f351d2e52584e626c8ff1f2aad940df4f8f0ee4c331ded62582804c3ce765 SHA512 9dadc0b7b1017ba19fb36232a32278c30628930b7c76a646ca343751754e10e1a1eb8a0c670ab308c437738ec28ceb324f6511ffb9c3bceabede01eb34b8a2e6
diff --git a/media-libs/cimg/cimg-2.6.7.ebuild b/media-libs/cimg/cimg-2.6.7.ebuild
new file mode 100644
index 000000000000..a3f01bc9ba22
--- /dev/null
+++ b/media-libs/cimg/cimg-2.6.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ template image processing toolkit"
+HOMEPAGE="https://cimg.eu/ https://github.com/dtschump/CImg"
+SRC_URI="https://github.com/dtschump/CImg/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-2 CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S=${WORKDIR}/CImg-v.${PV}
+
+src_install() {
+ doheader CImg.h
+ dodoc README.txt
+
+ use doc && dodoc -r html
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}