summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-09 09:33:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-09 09:33:45 +0100
commit6c52941361743eef55d07ce6e157895fb72209c9 (patch)
tree8ffca399a8f07846f3a9fd6d39f04320fdfcce35 /media-libs
parentMerge remote-tracking branch 'remotes/hydrapolic/filebeat' (diff)
downloadgentoo-6c52941361743eef55d07ce6e157895fb72209c9.tar.gz
gentoo-6c52941361743eef55d07ce6e157895fb72209c9.tar.bz2
gentoo-6c52941361743eef55d07ce6e157895fb72209c9.zip
media-libs/zimg: bump to 2.0.2
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/zimg/Manifest1
-rw-r--r--media-libs/zimg/zimg-2.0.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
index 0bd2aca20e52..a1a00fac6630 100644
--- a/media-libs/zimg/Manifest
+++ b/media-libs/zimg/Manifest
@@ -1 +1,2 @@
DIST zimg-2.0.1.tar.gz 174318 SHA256 be2557bf944dad07edbaf37d3fd5f1911627294b8d0992a8530048e84df082d8 SHA512 213952b2e51fad2f92d989104be188ff6cdc71b0910a1201a5f772e45b1fa90f522a62e85d8725037560e4505f40958a5497d731f3d03f7b890bfdaa5d0ae13c WHIRLPOOL 4918e22cc76a613a1641aba55f5f2d652186ef84a5719d250dfb499d0c8be8c7dd688dcf95d18e93f152479fad4a8543addf5c9a149fc030f354a090e741bcbb
+DIST zimg-2.0.2.tar.gz 174415 SHA256 b9c7bac9e6ad53dfa94215c28440167d72d41109df10278673789f8e531f2142 SHA512 f638e19d898c2c60009447d26e7098c1ec2aeac1d71234c17fa32e9d14a8506b549dae68c994b6be88938355bcf4e0f1f4efd5db7273ff15fa776260c978c123 WHIRLPOOL 859b7bcde2d6d3672312c8202df89e9c6c0aea2037e2c5179261ea39c6f321c8c872e7e1605bb225b97d3f1ef1942cba32ab96433c96816eee67f78e90b9fe5b
diff --git a/media-libs/zimg/zimg-2.0.2.ebuild b/media-libs/zimg/zimg-2.0.2.ebuild
new file mode 100644
index 000000000000..73b4cb907342
--- /dev/null
+++ b/media-libs/zimg/zimg-2.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}