summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-05-07 14:51:58 +0300
committerSam Jorna <wraeth@gentoo.org>2016-05-11 15:31:45 +1000
commit7335f1f57c3d596f2127608e225f09112b775277 (patch)
tree6c0c5eef134ebc829de057a401f22eda89cd37ef /media-libs
parentmedia-libs/libechonest: add live ebuild (diff)
downloadgentoo-7335f1f57c3d596f2127608e225f09112b775277.tar.gz
gentoo-7335f1f57c3d596f2127608e225f09112b775277.tar.bz2
gentoo-7335f1f57c3d596f2127608e225f09112b775277.zip
media-libs/libechonest: synchronise release and live ebuilds
Closes: https://github.com/gentoo/gentoo/pull/1395
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libechonest/libechonest-2.3.1-r1.ebuild16
-rw-r--r--media-libs/libechonest/libechonest-9999.ebuild2
2 files changed, 13 insertions, 5 deletions
diff --git a/media-libs/libechonest/libechonest-2.3.1-r1.ebuild b/media-libs/libechonest/libechonest-2.3.1-r1.ebuild
index c609bf30329c..7c1a828871a5 100644
--- a/media-libs/libechonest/libechonest-2.3.1-r1.ebuild
+++ b/media-libs/libechonest/libechonest-2.3.1-r1.ebuild
@@ -5,13 +5,19 @@
EAPI=6
inherit cmake-utils multibuild
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/lfranchi/libechonest.git"
+ inherit git-r3
+else
+ SRC_URI="http://files.lfranchi.com/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
DESCRIPTION="A library for communicating with The Echo Nest"
HOMEPAGE="https://projects.kde.org/projects/playground/libs/libechonest"
-SRC_URI="http://files.lfranchi.com/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0/2.3"
-KEYWORDS="~amd64 ~x86"
IUSE="+qt4 qt5"
REQUIRED_USE="|| ( qt4 qt5 )"
@@ -20,16 +26,18 @@ RESTRICT="test" # Networking required
RDEPEND="
qt4? (
- dev-libs/qjson[qt4(+)]
+ >=dev-libs/qjson-0.5[qt4(+)]
dev-qt/qtcore:4
)
qt5? (
dev-qt/qtcore:5
dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
)
"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
DOCS=( AUTHORS README TODO )
diff --git a/media-libs/libechonest/libechonest-9999.ebuild b/media-libs/libechonest/libechonest-9999.ebuild
index 7988f9c68dac..6531dfde0721 100644
--- a/media-libs/libechonest/libechonest-9999.ebuild
+++ b/media-libs/libechonest/libechonest-9999.ebuild
@@ -17,7 +17,7 @@ DESCRIPTION="A library for communicating with The Echo Nest"
HOMEPAGE="https://projects.kde.org/projects/playground/libs/libechonest"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="0/2.3"
IUSE="+qt4 qt5"
REQUIRED_USE="|| ( qt4 qt5 )"