summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-10-11 10:49:21 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-10-11 10:49:34 +0200
commit8646ba708a609540a181a627c35017e13a581436 (patch)
treec18c91a0156abd261ad2d54f109aa8c8358d29b4 /media-libs
parentapp-admin/sshguard: Version bump. (diff)
downloadgentoo-8646ba708a609540a181a627c35017e13a581436.tar.gz
gentoo-8646ba708a609540a181a627c35017e13a581436.tar.bz2
gentoo-8646ba708a609540a181a627c35017e13a581436.zip
media-libs/libsdl2: Bump to version 2.0.6
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl2/Manifest1
-rw-r--r--media-libs/libsdl2/files/libsdl2-2.0.6-static-libs.patch44
-rw-r--r--media-libs/libsdl2/libsdl2-2.0.6.ebuild170
3 files changed, 215 insertions, 0 deletions
diff --git a/media-libs/libsdl2/Manifest b/media-libs/libsdl2/Manifest
index 9441874a093d..350dca782245 100644
--- a/media-libs/libsdl2/Manifest
+++ b/media-libs/libsdl2/Manifest
@@ -1,2 +1,3 @@
DIST SDL2-2.0.4.tar.gz 4136230 SHA256 da55e540bf6331824153805d58b590a29c39d2d506c6d02fa409aedeab21174b SHA512 dd0a95878639856c0f4b8a579ace8071379ab64519fa139b22d3ed857a0f0db87a75bc8480c7207e02fbffd1fdbd448e3c0b882c451675b0e2f1a945af02e1d6 WHIRLPOOL 2203061d32d51552e5bcfaa9752de5cb3173c0c733698894de177f9a0c1bad73706633e2d232f9b893e4c3736a93aff00ae94eb044b19a05a1cdd7a4c030b574
DIST SDL2-2.0.5.tar.gz 4209352 SHA256 442038cf55965969f2ff06d976031813de643af9c9edc9e331bd761c242e8785 SHA512 6401f5df08c08316c09bc6ac5b28345c5184bb25770baa5c94c0a582ae130ddf73bb736e44bb31f4e427c1ddbbeec4755a6a5f530b6b4c3d0f13ebc78ddc1750 WHIRLPOOL 77aff6af67c29aab175f812be0aebbb65a757bd942de872b8330cb7cfabcd4abe0abd0c21b56bd409fb623b97c71981be5807e47dc03bf773aac85361582b796
+DIST SDL2-2.0.6.tar.gz 4420311 SHA256 03658b5660d16d7b31263a691e058ed37acdab155d68dabbad79998fb552c5df SHA512 ad4dad5663834ee0ffbdca1b531d753449b260c9256df2c48da7261aacd9795d91eef1286525cf914f6b92ba5985de7798f041557574b5d978b8224f10041830 WHIRLPOOL ad39ec811ac6f305a58352e1f332e9c29a34587c0eb2c9f163e76f93565418bd910210aea8113f53ca46bc745975ed8cc7b228f517af0a99d782fef44c4e0783
diff --git a/media-libs/libsdl2/files/libsdl2-2.0.6-static-libs.patch b/media-libs/libsdl2/files/libsdl2-2.0.6-static-libs.patch
new file mode 100644
index 000000000000..a1427a075b4c
--- /dev/null
+++ b/media-libs/libsdl2/files/libsdl2-2.0.6-static-libs.patch
@@ -0,0 +1,44 @@
+--- SDL2-2.0.6/configure.in
++++ SDL2-2.0.6/configure.in
+@@ -3546,7 +3546,7 @@
+ if test -f /lib/w32api/libuuid.a; then
+ LIBUUID=/lib/w32api/libuuid.a
+ else
+- LIBUUID=-luuid
++ LIBUUID=-Wl,-luuid
+ fi
+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS -luser32 -lgdi32 -lwinmm -limm32 -lole32 -loleaut32 -lshell32 -lversion $LIBUUID -static-libgcc"
+ # The Windows platform requires special setup
+@@ -3956,10 +3956,10 @@
+
+ VERSION_OBJECTS=`echo $VERSION_SOURCES`
+ VERSION_DEPENDS=`echo $VERSION_SOURCES`
+-VERSION_OBJECTS=`echo "$VERSION_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.rc,$(objects)/\1.o,g'`
++VERSION_OBJECTS=`echo "$VERSION_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.rc,$(objects)/\1.lo,g'`
+ VERSION_DEPENDS=`echo "$VERSION_DEPENDS" | sed "s,\\([[^ ]]*\\)/\\([[^ ]]*\\)\\.rc,\\\\
+-\\$(objects)/\\2.o: \\1/\\2.rc\\\\
+- \\$(WINDRES) \\$< \\$@,g"`
++\\$(objects)/\\2.lo: \\1/\\2.rc\\\\
++ \\$(LIBTOOL) --mode=compile --tag=RC \\$(WINDRES) -i \\$< -o \\$@,g"`
+
+ SDLMAIN_OBJECTS=`echo $SDLMAIN_SOURCES`
+ SDLMAIN_DEPENDS=`echo $SDLMAIN_SOURCES`
+--- SDL2-2.0.6/Makefile.in
++++ SDL2-2.0.6/Makefile.in
+@@ -143,13 +143,13 @@
+ .PHONY: all update-revision install install-bin install-hdrs install-lib install-data uninstall uninstall-bin uninstall-hdrs uninstall-lib uninstall-data clean distclean dist $(OBJECTS:.lo=.d)
+
+ $(objects)/$(TARGET): $(GEN_HEADERS) $(GEN_OBJECTS) $(OBJECTS) $(VERSION_OBJECTS)
+- $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ $(OBJECTS) $(GEN_OBJECTS) $(VERSION_OBJECTS) $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS)
++ $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS)
+
+ $(objects)/$(SDLMAIN_TARGET): $(SDLMAIN_OBJECTS)
+- $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) -static -o $@ $(SDLMAIN_OBJECTS) -rpath $(libdir)
++ $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS) -all-static
+
+ $(objects)/$(SDLTEST_TARGET): $(SDLTEST_OBJECTS)
+- $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) -static -o $@ $(SDLTEST_OBJECTS) -rpath $(libdir)
++ $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS) -all-static
+
+ install: all install-bin install-hdrs install-lib install-data
+ install-bin:
diff --git a/media-libs/libsdl2/libsdl2-2.0.6.ebuild b/media-libs/libsdl2/libsdl2-2.0.6.ebuild
new file mode 100644
index 000000000000..4117b57c829b
--- /dev/null
+++ b/media-libs/libsdl2/libsdl2-2.0.6.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: convert FusionSound #484250
+
+EAPI=6
+inherit autotools flag-o-matic toolchain-funcs ltprune multilib-minimal
+
+MY_P="SDL2-${PV}"
+DESCRIPTION="Simple Direct Media Layer"
+HOMEPAGE="http://www.libsdl.org"
+SRC_URI="http://www.libsdl.org/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+IUSE="cpu_flags_x86_3dnow alsa altivec custom-cflags dbus fusionsound gles haptic +joystick cpu_flags_x86_mmx nas opengl oss pulseaudio +sound cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs +threads tslib udev +video wayland X xinerama xscreensaver"
+REQUIRED_USE="
+ alsa? ( sound )
+ fusionsound? ( sound )
+ gles? ( video )
+ nas? ( sound )
+ opengl? ( video )
+ pulseaudio? ( sound )
+ wayland? ( gles )
+ xinerama? ( X )
+ xscreensaver? ( X )"
+
+RDEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ fusionsound? ( || ( >=media-libs/FusionSound-1.1.1 >=dev-libs/DirectFB-1.7.1[fusionsound] ) )
+ gles? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] )
+ nas? ( >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}] )
+ opengl? (
+ >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
+ >=virtual/glu-9.0-r1[${MULTILIB_USEDEP}]
+ )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ tslib? ( >=x11-libs/tslib-1.0-r3[${MULTILIB_USEDEP}] )
+ udev? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? (
+ >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}]
+ >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},egl,gles2,wayland]
+ >=x11-libs/libxkbcommon-0.2.0[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXcursor-1.1.14[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]
+ xinerama? ( >=x11-libs/libXinerama-1.1.3[${MULTILIB_USEDEP}] )
+ xscreensaver? ( >=x11-libs/libXScrnSaver-1.2.2-r1[${MULTILIB_USEDEP}] )
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ )
+ virtual/pkgconfig"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/SDL2/SDL_config.h
+)
+
+PATCHES=(
+ # https://bugzilla.libsdl.org/show_bug.cgi?id=1431
+ "${FILESDIR}"/${PN}-2.0.6-static-libs.patch
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -i -e 's/configure.in/configure.ac/' Makefile.in || die
+ mv configure.{in,ac} || die
+ AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf
+}
+
+multilib_src_configure() {
+ use custom-cflags || strip-flags
+
+ # sorted by `./configure --help`
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --enable-atomic
+ $(use_enable sound audio)
+ $(use_enable video)
+ --enable-render
+ --enable-events
+ $(use_enable joystick)
+ $(use_enable haptic)
+ --enable-power
+ --enable-filesystem
+ $(use_enable threads)
+ --enable-timers
+ --enable-file
+ --disable-loadso
+ --enable-cpuinfo
+ --enable-assembly
+ $(use_enable cpu_flags_x86_sse ssemath)
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable cpu_flags_x86_3dnow 3dnow)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable altivec)
+ $(use_enable oss)
+ $(use_enable alsa)
+ --disable-alsa-shared
+ --disable-esd
+ $(use_enable pulseaudio)
+ --disable-pulseaudio-shared
+ --disable-arts
+ $(use_enable nas)
+ --disable-nas-shared
+ --disable-sndio
+ --disable-sndio-shared
+ $(use_enable sound diskaudio)
+ $(use_enable sound dummyaudio)
+ $(use_enable wayland video-wayland)
+ --disable-wayland-shared
+ --disable-video-mir
+ $(use_enable X video-x11)
+ --disable-x11-shared
+ $(use_enable X video-x11-xcursor)
+ $(use_enable X video-x11-xdbe)
+ $(use_enable xinerama video-x11-xinerama)
+ $(use_enable X video-x11-xinput)
+ $(use_enable X video-x11-xrandr)
+ $(use_enable xscreensaver video-x11-scrnsaver)
+ $(use_enable X video-x11-xshape)
+ $(use_enable X video-x11-vm)
+ --disable-video-cocoa
+ --disable-video-directfb
+ $(multilib_native_use_enable fusionsound)
+ --disable-fusionsound-shared
+ $(use_enable video video-dummy)
+ $(use_enable opengl video-opengl)
+ --disable-video-opengles1
+ $(use_enable gles video-opengles2)
+ --disable-video-vulkan
+ $(use_enable udev libudev)
+ $(use_enable dbus)
+ --disable-ibus
+ $(use_enable tslib input-tslib)
+ --disable-directx
+ --disable-rpath
+ --disable-render-d3d
+ $(use_with X x)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ dodoc {BUGS,CREDITS,README,README-SDL,TODO,WhatsNew}.txt docs/README*.md
+}