summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-05-31 16:47:09 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-05-31 17:19:31 +0100
commit8b9daec6431c853fbdbd944fef316b603c5514ce (patch)
treeeae48aa8f63c748b3db50d5d9e7d5bee9232264d /media-libs
parentdev-libs/libuv: s390 stable wrt bug #716822 (diff)
downloadgentoo-8b9daec6431c853fbdbd944fef316b603c5514ce.tar.gz
gentoo-8b9daec6431c853fbdbd944fef316b603c5514ce.tar.bz2
gentoo-8b9daec6431c853fbdbd944fef316b603c5514ce.zip
media-libs/dumb: Bump to 2.0.3, EAPI 7, new upstream
This adds an allegro USE flag to replace the media-libs/aldumb package. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/dumb/Manifest1
-rw-r--r--media-libs/dumb/dumb-2.0.3.ebuild51
-rw-r--r--media-libs/dumb/files/dumb-2.0.3-pkg-config.patch21
-rw-r--r--media-libs/dumb/metadata.xml4
4 files changed, 77 insertions, 0 deletions
diff --git a/media-libs/dumb/Manifest b/media-libs/dumb/Manifest
index 089690e1d596..4f2c4403b6ae 100644
--- a/media-libs/dumb/Manifest
+++ b/media-libs/dumb/Manifest
@@ -1 +1,2 @@
DIST dumb-0.9.3.tar.gz 167379 BLAKE2B 1a9f62b784f8e8ba5b30b892bc9588bbebca7d5270b5d1161230c1c538d1aed8c6d2f2afa6a9087858ad45dccee9c640498548a845b2f046a0c390e7a84525cc SHA512 9ecdea460858b7e6ad7ca2534ecb3581397e6c1fa904459affe19ce49f528e580e143b42b13413b292ae7b57901a8008e6a9ee3821824f6ff7914b136f75c658
+DIST dumb-2.0.3.tar.gz 186576 BLAKE2B 0bd2e512b88260e67b11856630aecfdda2f11a8c5f931c1da3451dbfc15cd5e7e38e718d12b99e0598d9522cf259317a98c5d3088dd979c487a8971fd562ee3f SHA512 18b10a507d69a754cdf97fbeae41c17f211a6ba1f166a822276bdb6769d3edc326919067a3f4d1247d6715d7a5a8276669d83b9427e7336c6d111593fb7e36cf
diff --git a/media-libs/dumb/dumb-2.0.3.ebuild b/media-libs/dumb/dumb-2.0.3.ebuild
new file mode 100644
index 000000000000..7c509445721b
--- /dev/null
+++ b/media-libs/dumb/dumb-2.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Module/tracker based music format parser and player library"
+HOMEPAGE="https://github.com/kode54/dumb"
+SRC_URI="https://github.com/kode54/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="DUMB-0.9.3"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="allegro cpu_flags_x86_sse examples"
+
+RDEPEND="
+ allegro? (
+ media-libs/allegro:0[${MULTILIB_USEDEP}]
+ !media-libs/aldumb
+ )
+ examples? (
+ >=dev-libs/argtable-2
+ media-libs/libsdl2[sound]
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pkg-config.patch
+)
+
+DOCS=(
+ CHANGELOG.md
+ DUMBFILE_SYSTEM.md
+ README.md
+ UPDATING_YOUR_PROJECTS.md
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_ALLEGRO4=$(usex allegro)
+ -DBUILD_EXAMPLES=$(multilib_native_usex examples)
+ -DUSE_SSE=$(usex cpu_flags_x86_sse)
+ )
+ cmake_src_configure
+}
diff --git a/media-libs/dumb/files/dumb-2.0.3-pkg-config.patch b/media-libs/dumb/files/dumb-2.0.3-pkg-config.patch
new file mode 100644
index 000000000000..5b8d9856e171
--- /dev/null
+++ b/media-libs/dumb/files/dumb-2.0.3-pkg-config.patch
@@ -0,0 +1,21 @@
+From 3a4f71afbc23d716d0d1f71664b94af143ae8e11 Mon Sep 17 00:00:00 2001
+From: Robert Colton <robertbcolton@gmail.com>
+Date: Tue, 18 Dec 2018 22:03:51 -0500
+Subject: [PATCH] fix pkg-config linking issue -llibdumb
+
+---
+ pkg-config.pc.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pkg-config.pc.in b/pkg-config.pc.in
+index c11861c..92a9735 100644
+--- a/pkg-config.pc.in
++++ b/pkg-config.pc.in
+@@ -7,6 +7,6 @@ Name: DUMB
+ Description: DUMB is a module audio renderer library.
+ Version: @DUMB_VERSION@
+ URL: https://github.com/kode54/dumb/
+-Libs: -L${libdir} -l@PROJECT_NAME@
++Libs: -L${libdir} -ldumb
+ Libs.private: -lm
+ Cflags: -I${includedir}
diff --git a/media-libs/dumb/metadata.xml b/media-libs/dumb/metadata.xml
index 18f5db992196..66e3068bc83d 100644
--- a/media-libs/dumb/metadata.xml
+++ b/media-libs/dumb/metadata.xml
@@ -6,6 +6,10 @@
<name>Gentoo Sound project</name>
</maintainer>
<upstream>
+ <remote-id type="github">kode54/dumb</remote-id>
<remote-id type="sourceforge">dumb</remote-id>
</upstream>
+ <use>
+ <flag name="allegro">Add support for Allegro 4</flag>
+ </use>
</pkgmetadata>