summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-10-11 01:23:17 +0200
committerAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-10-11 01:23:17 +0200
commit8fcd35dbc3da4a84384486f1012f165e2b68750b (patch)
tree86416a94ce2011b828301a17d14c79af009436d1 /media-libs
parentapp-office/libreoffice: Add 5.0.3 pre-release (diff)
downloadgentoo-8fcd35dbc3da4a84384486f1012f165e2b68750b.tar.gz
gentoo-8fcd35dbc3da4a84384486f1012f165e2b68750b.tar.bz2
gentoo-8fcd35dbc3da4a84384486f1012f165e2b68750b.zip
media-libs/libvisio: Revision bump fixes tests and build w/ boost-1.59
See also https://bugs.gentoo.org/show_bug.cgi?id=556922 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libvisio/files/libvisio-0.1.3-boost-1.59.patch22
-rw-r--r--media-libs/libvisio/files/libvisio-0.1.3-fix-tests.patch49
-rw-r--r--media-libs/libvisio/libvisio-0.1.3-r1.ebuild57
3 files changed, 128 insertions, 0 deletions
diff --git a/media-libs/libvisio/files/libvisio-0.1.3-boost-1.59.patch b/media-libs/libvisio/files/libvisio-0.1.3-boost-1.59.patch
new file mode 100644
index 000000000000..a0102e8edcb4
--- /dev/null
+++ b/media-libs/libvisio/files/libvisio-0.1.3-boost-1.59.patch
@@ -0,0 +1,22 @@
+From: David Tardon <dtardon@redhat.com>
+Date: Sun, 30 Aug 2015 11:59:23 +0000 (+0200)
+Subject: fix build with boost 1.59
+X-Git-Url: https://gerrit.libreoffice.org/gitweb?p=libvisio.git;a=commitdiff_plain;h=2968c3dff8572b4734cb42c7bd5b00222f7fb288;hp=4b03893826bcc5f859b0ac3bea6a98269499d99f
+
+fix build with boost 1.59
+
+Change-Id: I21eebdfa99d379e57949bfe4bf7eb83aec16f916
+---
+
+diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
+index dc0f8fd..6946b0a 100644
+--- a/src/lib/Makefile.am
++++ b/src/lib/Makefile.am
+@@ -22,6 +22,7 @@ generated_files = \
+ $(top_builddir)/src/lib/tokens.h \
+ $(top_builddir)/src/lib/tokenhash.h
+
++libvisio_@VSD_MAJOR_VERSION@_@VSD_MINOR_VERSION@_la_CPPFLAGS = -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED
+ libvisio_@VSD_MAJOR_VERSION@_@VSD_MINOR_VERSION@_la_LIBADD = $(LIBVISIO_LIBS) @LIBVISIO_WIN32_RESOURCE@
+ libvisio_@VSD_MAJOR_VERSION@_@VSD_MINOR_VERSION@_la_DEPENDENCIES = @LIBVISIO_WIN32_RESOURCE@
+ libvisio_@VSD_MAJOR_VERSION@_@VSD_MINOR_VERSION@_la_LDFLAGS = $(version_info) -export-dynamic -no-undefined
diff --git a/media-libs/libvisio/files/libvisio-0.1.3-fix-tests.patch b/media-libs/libvisio/files/libvisio-0.1.3-fix-tests.patch
new file mode 100644
index 000000000000..19104a143c3c
--- /dev/null
+++ b/media-libs/libvisio/files/libvisio-0.1.3-fix-tests.patch
@@ -0,0 +1,49 @@
+From 75a02c586f6ec49d4316f79004834250ef42b0e0 Mon Sep 17 00:00:00 2001
+From: David Tardon <dtardon@redhat.com>
+Date: Sat, 25 Jul 2015 15:11:19 +0200
+Subject: [PATCH] fix test
+
+The previous version only worked with libxml2 < 2.9.2, because of a bug
+in handling nested elements of the same name.
+
+Change-Id: I1368cedf5845895154806d4ecf427bfbed19165f
+---
+ configure.ac | 4 ++++
+ src/test/importtest.cpp | 6 +++---
+ 2 files changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 1611dcb..a075e73 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -128,6 +128,10 @@ AS_IF([test "x$enable_tools" = "xyes"], [
+ PKG_CHECK_MODULES([REVENGE_STREAM],[
+ librevenge-stream-0.0
+ ])
++ PKG_CHECK_EXISTS([libxml-2.0 >= 2.9.2],
++ [],
++ [AC_MSG_ERROR([libxml2 >= 2.9.2 is needed to run tests])]
++ )
+ ])
+ AC_SUBST([REVENGE_GENERATORS_CFLAGS])
+ AC_SUBST([REVENGE_GENERATORS_LIBS])
+diff --git a/src/test/importtest.cpp b/src/test/importtest.cpp
+index 8554309..0296380 100644
+--- a/src/test/importtest.cpp
++++ b/src/test/importtest.cpp
+@@ -272,9 +272,9 @@ void ImportTest::testVsdxImportBgColorFromTheme()
+ void ImportTest::testVsdxCharBgColor()
+ {
+ m_doc = parse("bgcolor.vsdx", m_buffer);
+- assertXPathNoAttribute(m_doc, "/document/page/layer/textObject/paragraph/span", "background-color");
+- assertXPath(m_doc, "/document/page/layer/layer[2]/textObject/paragraph/span", "background-color", "#9dbb61");
+- assertXPath(m_doc, "/document/page/layer/layer[2]/layer[2]/textObject/paragraph/span", "background-color", "#9dbb61");
++ assertXPathNoAttribute(m_doc, "/document/page/layer[1]/textObject/paragraph/span", "background-color");
++ assertXPath(m_doc, "/document/page/layer[2]/textObject/paragraph/span", "background-color", "#9dbb61");
++ assertXPath(m_doc, "/document/page/layer[3]/textObject/paragraph/span", "background-color", "#9dbb61");
+ }
+
+ CPPUNIT_TEST_SUITE_REGISTRATION(ImportTest);
+--
+1.7.9.5
+
diff --git a/media-libs/libvisio/libvisio-0.1.3-r1.ebuild b/media-libs/libvisio/libvisio-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..0770f0fd1d4a
--- /dev/null
+++ b/media-libs/libvisio/libvisio-0.1.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing the visio documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE="doc static-libs test tools"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ dev-util/gperf
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-tests.patch" \
+ "${FILESDIR}/${P}-boost-1.59.patch"
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}