summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 10:58:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:26:14 +0100
commit9a1e950a695230c82b4b7bf1117f553b233b3671 (patch)
tree4c01853f5059c69dcb53b60a504cdfc07ac8dea9 /media-libs
parentmedia-libs/libmygpo-qt: Switch to cmake.eclass, EAPI-7 bump (diff)
downloadgentoo-9a1e950a695230c82b4b7bf1117f553b233b3671.tar.gz
gentoo-9a1e950a695230c82b4b7bf1117f553b233b3671.tar.bz2
gentoo-9a1e950a695230c82b4b7bf1117f553b233b3671.zip
media-libs/libsfml: EAPI-7 bump, switch to cmake.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsfml/libsfml-2.5.1.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/media-libs/libsfml/libsfml-2.5.1.ebuild b/media-libs/libsfml/libsfml-2.5.1.ebuild
index 159102d00492..2b975f17c8fc 100644
--- a/media-libs/libsfml/libsfml-2.5.1.ebuild
+++ b/media-libs/libsfml/libsfml-2.5.1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils eapi7-ver
+EAPI=7
-MY_P="SFML-${PV}"
+inherit cmake
DESCRIPTION="Simple and Fast Multimedia Library (SFML)"
HOMEPAGE="https://www.sfml-dev.org/ https://github.com/SFML/SFML"
@@ -33,21 +32,21 @@ RDEPEND="
x11-libs/xcb-util-image
)
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
doc? ( app-doc/doxygen )
"
DOCS=( changelog.md readme.md )
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}/SFML-${PV}"
src_prepare() {
sed -i "s:DESTINATION .*:DESTINATION /usr/share/doc/${PF}:" \
doc/CMakeLists.txt || die
find examples -name CMakeLists.txt -delete || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -59,11 +58,11 @@ src_configure() {
if use kernel_Winnt; then
mycmakeargs+=( -DSFML_USE_SYSTEM_DEPS=TRUE )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
insinto /usr/share/cmake/Modules
doins cmake/SFMLConfig.cmake.in