summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHector Martin <marcan@marcan.st>2019-02-10 11:47:44 +0900
committerPatrice Clement <monsieurp@gentoo.org>2019-02-16 23:29:20 +0100
commita0fdf81573f199b4ef5aa9178c67e7abc492c719 (patch)
tree0943d0702bfc2b1f5fa33c77f196ab1a1ee6e1bb /media-libs
parentwww-plugins/passff: fix installation method. (diff)
downloadgentoo-a0fdf81573f199b4ef5aa9178c67e7abc492c719.tar.gz
gentoo-a0fdf81573f199b4ef5aa9178c67e7abc492c719.tar.bz2
gentoo-a0fdf81573f199b4ef5aa9178c67e7abc492c719.zip
media-libs/aribb24-1.0.3-r1: enable multilib, bump to EAPI 7.
Signed-off-by: Hector Martin <marcan@marcan.st> Package-Manager: Portage-2.3.59, Repoman-2.3.12 Closes: https://github.com/gentoo/gentoo/pull/11014 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/aribb24/aribb24-1.0.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/aribb24/aribb24-1.0.3-r1.ebuild b/media-libs/aribb24/aribb24-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..a6cba5266077
--- /dev/null
+++ b/media-libs/aribb24/aribb24-1.0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Library for decoding ARIB STD-B24 subtitles"
+HOMEPAGE="https://github.com/nkoriyama/aribb24"
+SRC_URI="https://github.com/nkoriyama/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="media-libs/libpng:0=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+ find "${D}" -name '*.la' -delete || die
+}