summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-07 14:36:23 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-07 14:43:47 -0400
commitae62b66d2857c70d7c0437438f30f63555edb073 (patch)
tree1944864d87079b43497cb6382cc6dff9134fbca6 /media-libs
parentx11-misc/rodent: Version bump to 5.3.16.3 (diff)
downloadgentoo-ae62b66d2857c70d7c0437438f30f63555edb073.tar.gz
gentoo-ae62b66d2857c70d7c0437438f30f63555edb073.tar.bz2
gentoo-ae62b66d2857c70d7c0437438f30f63555edb073.zip
media-libs/freetype: add upstream fix for bad shifts w/some bad fonts
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/freetype/files/freetype-2.6.1-bad-shift.patch50
-rw-r--r--media-libs/freetype/freetype-2.6.1-r1.ebuild163
2 files changed, 213 insertions, 0 deletions
diff --git a/media-libs/freetype/files/freetype-2.6.1-bad-shift.patch b/media-libs/freetype/files/freetype-2.6.1-bad-shift.patch
new file mode 100644
index 000000000000..c361baf2a06f
--- /dev/null
+++ b/media-libs/freetype/files/freetype-2.6.1-bad-shift.patch
@@ -0,0 +1,50 @@
+taken from upstream
+
+http://savannah.nongnu.org/bugs/?func=detailitem&item_id=46118
+
+From 30fe5e762e062612fdf4b56b50d813525a5aa311 Mon Sep 17 00:00:00 2001
+From: Werner Lemberg <wl@gnu.org>
+Date: Sun, 4 Oct 2015 13:08:08 +0200
+Subject: [PATCH] [base] Replace left shifts with multiplication (#46118).
+
+* src/base/ftglyph.c (ft_bitmap_glyph_bbox, FT_Get_Glyph): Do it.
+---
+ ChangeLog | 6 ++++++
+ src/base/ftglyph.c | 14 +++++++-------
+ 2 files changed, 13 insertions(+), 7 deletions(-)
+
+diff --git a/src/base/ftglyph.c b/src/base/ftglyph.c
+index cb7fc37..2778743 100644
+--- a/src/base/ftglyph.c
++++ b/src/base/ftglyph.c
+@@ -125,10 +125,10 @@
+ FT_BitmapGlyph glyph = (FT_BitmapGlyph)bitmap_glyph;
+
+
+- cbox->xMin = glyph->left << 6;
+- cbox->xMax = cbox->xMin + (FT_Pos)( glyph->bitmap.width << 6 );
+- cbox->yMax = glyph->top << 6;
+- cbox->yMin = cbox->yMax - (FT_Pos)( glyph->bitmap.rows << 6 );
++ cbox->xMin = glyph->left * 64;
++ cbox->xMax = cbox->xMin + (FT_Pos)( glyph->bitmap.width * 64 );
++ cbox->yMax = glyph->top * 64;
++ cbox->yMin = cbox->yMax - (FT_Pos)( glyph->bitmap.rows * 64 );
+ }
+
+
+@@ -403,9 +403,9 @@
+ if ( error )
+ goto Exit;
+
+- /* copy advance while converting it to 16.16 format */
+- glyph->advance.x = slot->advance.x << 10;
+- glyph->advance.y = slot->advance.y << 10;
++ /* copy advance while converting 26.6 to 16.16 format */
++ glyph->advance.x = slot->advance.x * 1024;
++ glyph->advance.y = slot->advance.y * 1024;
+
+ /* now import the image from the glyph slot */
+ error = clazz->glyph_init( glyph, slot );
+--
+2.5.2
+
diff --git a/media-libs/freetype/freetype-2.6.1-r1.ebuild b/media-libs/freetype/freetype-2.6.1-r1.ebuild
new file mode 100644
index 000000000000..de89f3921c71
--- /dev/null
+++ b/media-libs/freetype/freetype-2.6.1-r1.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-multilib flag-o-matic multilib toolchain-funcs
+
+INFINALITY_PATCH="03-infinality-2.6-2015.10.04.patch"
+
+DESCRIPTION="A high-quality and portable font engine"
+HOMEPAGE="http://www.freetype.org/"
+SRC_URI="mirror://sourceforge/freetype/${P/_/}.tar.bz2
+ mirror://nongnu/freetype/${P/_/}.tar.bz2
+ utils? ( mirror://sourceforge/freetype/ft2demos-${PV}.tar.bz2
+ mirror://nongnu/freetype/ft2demos-${PV}.tar.bz2 )
+ doc? ( mirror://sourceforge/freetype/${PN}-doc-${PV}.tar.bz2
+ mirror://nongnu/freetype/${PN}-doc-${PV}.tar.bz2 )
+ infinality? ( https://dev.gentoo.org/~polynomial-c/${INFINALITY_PATCH}.xz )"
+
+LICENSE="|| ( FTL GPL-2+ )"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="X +adobe-cff bindist bzip2 debug doc fontforge harfbuzz
+ infinality png static-libs utils"
+RESTRICT="!bindist? ( bindist )" # bug 541408
+
+CDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
+ harfbuzz? ( >=media-libs/harfbuzz-0.9.19[truetype,${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.2.51:=[${MULTILIB_USEDEP}] )
+ utils? (
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]
+ )
+ )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ abi_x86_32? ( utils? ( !app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)] ) )"
+PDEPEND="infinality? ( media-libs/fontconfig-infinality )"
+
+src_prepare() {
+ enable_option() {
+ sed -i -e "/#define $1/a #define $1" \
+ include/${PN}/config/ftoption.h \
+ || die "unable to enable option $1"
+ }
+
+ disable_option() {
+ sed -i -e "/#define $1/ { s:^:/*:; s:$:*/: }" \
+ include/${PN}/config/ftoption.h \
+ || die "unable to disable option $1"
+ }
+
+ # This is the same as the 01 patch from infinality
+ epatch "${FILESDIR}"/${PN}-2.3.2-enable-valid.patch
+
+ if use infinality; then
+ epatch "${WORKDIR}/${INFINALITY_PATCH}"
+
+ # FT_CONFIG_OPTION_SUBPIXEL_RENDERING is already enabled in freetype-2.4.11
+ enable_option TT_CONFIG_OPTION_SUBPIXEL_HINTING
+ fi
+
+ if ! use bindist; then
+ # See http://freetype.org/patents.html
+ # ClearType is covered by several Microsoft patents in the US
+ enable_option FT_CONFIG_OPTION_SUBPIXEL_RENDERING
+ fi
+
+ if ! use adobe-cff; then
+ enable_option CFF_CONFIG_OPTION_OLD_ENGINE
+ fi
+
+ if use debug; then
+ enable_option FT_DEBUG_LEVEL_TRACE
+ enable_option FT_DEBUG_MEMORY
+ fi
+
+ epatch "${FILESDIR}"/${PN}-2.4.11-sizeof-types.patch # 459966
+ epatch "${FILESDIR}"/${PN}-2.6.1-bad-shift.patch
+
+ if use utils; then
+ cd "${WORKDIR}/ft2demos-${PV}" || die
+ # Disable tests needing X11 when USE="-X". (bug #177597)
+ if ! use X; then
+ sed -i -e "/EXES\ +=\ ftdiff/ s:^:#:" Makefile || die
+ fi
+ cd "${S}" || die
+ fi
+
+ # we need non-/bin/sh to run configure
+ if [[ -n ${CONFIG_SHELL} ]] ; then
+ sed -i -e "1s:^#![[:space:]]*/bin/sh:#!$CONFIG_SHELL:" \
+ "${S}"/builds/unix/configure || die
+ fi
+
+ autotools-utils_src_prepare
+}
+
+multilib_src_configure() {
+ append-flags -fno-strict-aliasing
+ type -P gmake &> /dev/null && export GNUMAKE=gmake
+
+ local myeconfargs=(
+ --enable-biarch-config
+ $(use_with bzip2)
+ $(use_with harfbuzz)
+ $(use_with png)
+
+ # avoid using libpng-config
+ LIBPNG_CFLAGS="$($(tc-getPKG_CONFIG) --cflags libpng)"
+ LIBPNG_LDFLAGS="$($(tc-getPKG_CONFIG) --libs libpng)"
+ )
+
+ autotools-utils_src_configure
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use utils; then
+ einfo "Building utils"
+ # fix for Prefix, bug #339334
+ emake \
+ X11_PATH="${EPREFIX}/usr/$(get_libdir)" \
+ FT2DEMOS=1 TOP_DIR_2="${WORKDIR}/ft2demos-${PV}"
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi && use utils; then
+ einfo "Installing utils"
+ rm "${WORKDIR}"/ft2demos-${PV}/bin/README || die
+ local ft2demo
+ for ft2demo in ../ft2demos-${PV}/bin/*; do
+ ./libtool --mode=install $(type -P install) -m 755 "$ft2demo" \
+ "${ED}"/usr/bin || die
+ done
+ fi
+}
+
+multilib_src_install_all() {
+ if use fontforge; then
+ # Probably fontforge needs less but this way makes things simplier...
+ einfo "Installing internal headers required for fontforge"
+ local header
+ find src/truetype include/internal -name '*.h' | \
+ while read header; do
+ mkdir -p "${ED}/usr/include/freetype2/internal4fontforge/$(dirname ${header})" || die
+ cp ${header} "${ED}/usr/include/freetype2/internal4fontforge/$(dirname ${header})" || die
+ done
+ fi
+
+ dodoc docs/{CHANGES,CUSTOMIZE,DEBUG,INSTALL.UNIX,*.txt,PROBLEMS,TODO}
+ use doc && dohtml -r docs/*
+
+ prune_libtool_files --all
+}