summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-24 13:34:15 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-24 13:34:15 +0100
commitb03d3f230b254f2d463be8d0b81a406cf7110b7d (patch)
tree1f0df1975b219868b096145821ed9f0eb6cd8209 /media-libs
parentdev-python/pid: bump to 2.2.0, add test deps and more python compat (diff)
downloadgentoo-b03d3f230b254f2d463be8d0b81a406cf7110b7d.tar.gz
gentoo-b03d3f230b254f2d463be8d0b81a406cf7110b7d.tar.bz2
gentoo-b03d3f230b254f2d463be8d0b81a406cf7110b7d.zip
media-libs/zimg: bump to 2.7.4
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/zimg/Manifest1
-rw-r--r--media-libs/zimg/zimg-2.7.4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
index 9a040bff121b..c33759e7dd85 100644
--- a/media-libs/zimg/Manifest
+++ b/media-libs/zimg/Manifest
@@ -1,3 +1,4 @@
DIST zimg-2.5.1.tar.gz 213083 BLAKE2B d0ea74d409fa19b6e9ed946c70d2c41d0ee35e38955b8c14eba9c9f769405db97fc4884043ab378c2e4c36540fae524ce97173ecd2e30f6ecde12bc579327a88 SHA512 c16402ee7aff40b811cd8c69c1e5d5f13775e628f3d5300e82548b6cc97d17e5317fa58d498a0cb4f7699d4eb2d1f424c3f4d9858f4cfbdda36612d6693961a0
DIST zimg-2.5.tar.gz 213054 BLAKE2B 0532693c11c1b2bcc0d5bde3a0bc16bf4f736ceff5fcda5d9bf491fcebe7e8be538041cc536e40bc110e438370c8599ce0be35f71cea00429b16c6eeb680cb86 SHA512 7fc48c704b434d837c36d4bafc51b35789eaf90fc81a68dcd7ec546f1e82a3e41c53263f8d381541d5c0ce58e25dddf0adaf1c3575512842ae633b5581778938
DIST zimg-2.6.3.tar.gz 238372 BLAKE2B 4651381c61b978bedd78871117fbe0b1be7e40e3b0d32b399ab47cab06d596befb61078a6f979f2a2ea962ba66046f776e18a2bbf304dee4a2428b303a3094a7 SHA512 497d3b5b0c004fe720c9be2460f251196789ed055a0081b774c78f8c311dc097c2b5d975cb0a7d41e819ca21527e961186b665b5791032787c3b30647011e7da
+DIST zimg-2.7.4.tar.gz 246376 BLAKE2B b6a21a1f7ca5106810485a69bb4e8f1d59d67fe3a619fd0ac412b1e441fe2d8892f64826666fbdfa48ae441fa5a21512b5ba0977eeaca7dcb7e0fcc43447f6e4 SHA512 adbb525b2611ef5267a4c0d4e8c6dd164c2814241c4d58d5356545b23dcf0cbeabb140141ae6ff0e70ef8e0741e351cbfadbadd60923061ddd693a2c3d9e5fde
diff --git a/media-libs/zimg/zimg-2.7.4.ebuild b/media-libs/zimg/zimg-2.7.4.ebuild
new file mode 100644
index 000000000000..f33de9c2c99e
--- /dev/null
+++ b/media-libs/zimg/zimg-2.7.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+SCM=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+fi
+
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="static-libs cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ autotools-multilib_src_configure \
+ $(use_enable cpu_flags_x86_sse x86simd)
+}