summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-08 00:06:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-09 18:28:07 +0100
commitd4c7e46a79cb8e529a2512e22852a0750392c595 (patch)
treea17031fa63f81b0a744341e8c2d92dd2ef952384 /media-libs
parentmedia-gfx/krita: 3.3.3 version bump (diff)
downloadgentoo-d4c7e46a79cb8e529a2512e22852a0750392c595.tar.gz
gentoo-d4c7e46a79cb8e529a2512e22852a0750392c595.tar.bz2
gentoo-d4c7e46a79cb8e529a2512e22852a0750392c595.zip
media-libs/avidemux-core: Sorting, fix DESCRIPTION
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/avidemux-core/avidemux-core-9999.ebuild39
1 files changed, 20 insertions, 19 deletions
diff --git a/media-libs/avidemux-core/avidemux-core-9999.ebuild b/media-libs/avidemux-core/avidemux-core-9999.ebuild
index 6d3d4eb7d5f9..b99cdefa4506 100644
--- a/media-libs/avidemux-core/avidemux-core-9999.ebuild
+++ b/media-libs/avidemux-core/avidemux-core-9999.ebuild
@@ -1,22 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils
-
-DESCRIPTION="Core libraries for a video editor designed for simple cutting, filtering and encoding tasks"
-HOMEPAGE="http://fixounet.free.fr/avidemux"
-
-# Multiple licenses because of all the bundled stuff.
-LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
-SLOT="2.6"
-IUSE="debug nls nvenc sdl system-ffmpeg vaapi vdpau xv"
-
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/mean00/avidemux2.git"
EGIT_CHECKOUT_DIR=${WORKDIR}
-
inherit git-r3
else
MY_PN="${PN/-core/}"
@@ -24,6 +13,15 @@ else
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
+inherit cmake-utils
+
+DESCRIPTION="Core libraries for simple video cutting, filtering and encoding tasks"
+HOMEPAGE="http://fixounet.free.fr/avidemux"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+SLOT="2.6"
+IUSE="debug nls nvenc sdl system-ffmpeg vaapi vdpau xv"
# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
COMMON_DEPEND="
@@ -52,13 +50,16 @@ src_prepare() {
cmake-utils_src_prepare
if use system-ffmpeg ; then
- # Preparations to support the system ffmpeg. Currently fails because it depends on files the system ffmpeg doesn't install.
- local error="Failed to remove ffmpeg."
-
- rm -rf cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "${error}"
- sed -i -e 's/include(admFFmpegUtil)//g' avidemux/commonCmakeApplication.cmake || die "${error}"
- sed -i -e '/registerFFmpeg/d' avidemux/commonCmakeApplication.cmake || die "${error}"
- sed -i -e 's/include(admFFmpegBuild)//g' avidemux_core/CMakeLists.txt || die "${error}"
+ # Preparations to support the system ffmpeg. Currently fails because
+ # it depends on files the system ffmpeg doesn't install.
+ local error="Failed to remove bundled ffmpeg."
+
+ rm -r cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package \
+ buildCore/ffmpeg || die "${error}"
+ sed -e 's/include(admFFmpegUtil)//g' -e '/registerFFmpeg/d' \
+ -i avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -e 's/include(admFFmpegBuild)//g' \
+ -i avidemux_core/CMakeLists.txt || die "${error}"
fi
}