summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-01 20:01:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-01 20:01:00 +0100
commitd5dc8e78ddcb7293d31bd54eef052aed39b3be7b (patch)
tree0cdc05c74f95179d3b7d2e1099977f1ae5c69aa7 /media-libs
parentsci-libs/gdal: Fix build with poppler-0.82.0 (diff)
downloadgentoo-d5dc8e78ddcb7293d31bd54eef052aed39b3be7b.tar.gz
gentoo-d5dc8e78ddcb7293d31bd54eef052aed39b3be7b.tar.bz2
gentoo-d5dc8e78ddcb7293d31bd54eef052aed39b3be7b.zip
media-libs/libfreehand: Fix build against ICU-65
Closes: https://bugs.gentoo.org/699096 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libfreehand/files/libfreehand-0.1.2-icu-65.patch26
-rw-r--r--media-libs/libfreehand/libfreehand-0.1.2.ebuild2
2 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/libfreehand/files/libfreehand-0.1.2-icu-65.patch b/media-libs/libfreehand/files/libfreehand-0.1.2-icu-65.patch
new file mode 100644
index 000000000000..a24664952252
--- /dev/null
+++ b/media-libs/libfreehand/files/libfreehand-0.1.2-icu-65.patch
@@ -0,0 +1,26 @@
+From af3197f795625f5188602073205a34369698b6df Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Fri, 4 Oct 2019 01:46:12 +0200
+Subject: [PATCH] Add missing semicolon to fix build with icu 65.1
+
+Change-Id: I7a0b0d600e9f7770245a7485813a944bfac4f088
+Reviewed-on: https://gerrit.libreoffice.org/80224
+Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
+Tested-by: Miklos Vajna <vmiklos@collabora.com>
+---
+ src/lib/libfreehand_utils.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/lib/libfreehand_utils.cpp b/src/lib/libfreehand_utils.cpp
+index 439c457..32f23e0 100644
+--- a/src/lib/libfreehand_utils.cpp
++++ b/src/lib/libfreehand_utils.cpp
+@@ -162,7 +162,7 @@ void libfreehand::_appendUTF16(librevenge::RVNGString &text, std::vector<unsigne
+ while (j < length)
+ {
+ UChar32 c;
+- U16_NEXT(s, j, length, c)
++ U16_NEXT(s, j, length, c);
+ unsigned char outbuf[U8_MAX_LENGTH+1];
+ int i = 0;
+ U8_APPEND_UNSAFE(&outbuf[0], i, c);
diff --git a/media-libs/libfreehand/libfreehand-0.1.2.ebuild b/media-libs/libfreehand/libfreehand-0.1.2.ebuild
index f27b47bb1398..ac35aa0e43ab 100644
--- a/media-libs/libfreehand/libfreehand-0.1.2.ebuild
+++ b/media-libs/libfreehand/libfreehand-0.1.2.ebuild
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
test? ( dev-util/cppunit )
"
+PATCHES=( "${FILESDIR}/${P}-icu-65.patch" )
+
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"