summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-06-15 13:31:39 -0700
committerMatt Turner <mattst88@gentoo.org>2020-06-15 14:04:50 -0700
commitd5dea1dc4455fb41579ddd071f02b1a1a553b853 (patch)
tree1aa0c87aa41a849af28aa2393e1cff8e990f85e1 /media-libs
parentdev-util/glslang: Drop x11@ as a maintainer (diff)
downloadgentoo-d5dea1dc4455fb41579ddd071f02b1a1a553b853.tar.gz
gentoo-d5dea1dc4455fb41579ddd071f02b1a1a553b853.tar.bz2
gentoo-d5dea1dc4455fb41579ddd071f02b1a1a553b853.zip
media-libs/shaderc: Version bump to 2020.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/shaderc/Manifest1
-rw-r--r--media-libs/shaderc/files/shaderc-2020.1-fix-build.patch17
-rw-r--r--media-libs/shaderc/shaderc-2020.1.ebuild87
3 files changed, 105 insertions, 0 deletions
diff --git a/media-libs/shaderc/Manifest b/media-libs/shaderc/Manifest
index 9811b2fe18ef..a5a202aab660 100644
--- a/media-libs/shaderc/Manifest
+++ b/media-libs/shaderc/Manifest
@@ -1,3 +1,4 @@
DIST shaderc-2018.0.tar.gz 206013 BLAKE2B b45fb6e959f621566817f8e31b1947e479b6ea392eb64f334dca9ad24cc4e8b736dd236e634de3f96342f48d8138722a2b769efb9db65025def5ed59bf5b911b SHA512 7a420fde73c9f2aae3f13558d538a1f4ae43bba19e2b4d2da8fbbd017e9e4f328ece5f330f1bbcb9fe84c91b7eb84b9158dc2e3d144c82939090a0fa6f5b4ef0
DIST shaderc-2019.0.tar.gz 232620 BLAKE2B 53fd0967fe22e5a89783fccb485dc07c31a18eb328c6cf7244349714c6774d1877c1fbae0b8ffcf47d189f1e0c5f2d501f027ff3aa05bdd59950d49a4084e9b5 SHA512 c76887ad0a96145211b6550b0dfe63091df9e1463f9a3140aba2d1982c33e98ad14fb4bcf9ce2281433fc77626fc892c268d0636b9f348a159dd06e3f41b461a
+DIST shaderc-2020.1.tar.gz 276137 BLAKE2B 06466db46b244001c36523ccf218b0485a46864465eda4c605889f65e3acbbbae9f1f7e30c183352f39fb09b1d2b2e87bde26092f1c415de3c55f9d5dde839d2 SHA512 3f53b0be4a15b5b3da0778f2275c7f69579482ee8253b77b4127c4db13a94fbf1e39b3daabafc8642b2d3351acdceed45996af6cbfe310cfaa6cea3a666d828e
DIST shaderc-2020.4_pre20200405.tar.gz 273897 BLAKE2B 6cd02d0db17d0c92b3f2b65bd46284b8432538e3899e088c2e08648a6797ed596af13e251afdf0c1747abc27fa49b56df32ce67beb72c6e99a6bda463cf9dea1 SHA512 556d519faf6e3df6efbe77a24b21e74198468b0638dd7c3143228afce5625f04707fa77aaec997998795166705271e2e8d086cd2e82609eaaef786ea36554ac4
diff --git a/media-libs/shaderc/files/shaderc-2020.1-fix-build.patch b/media-libs/shaderc/files/shaderc-2020.1-fix-build.patch
new file mode 100644
index 000000000000..f46aa5ddb668
--- /dev/null
+++ b/media-libs/shaderc/files/shaderc-2020.1-fix-build.patch
@@ -0,0 +1,17 @@
+This patch is a revert of commit 15a66d72f33a099ec65e0fd37cf14548ed1d2bdb (Rolling 5 dependencies and fixing build (#1057)) because it adds usage of the .maxDualSourceDrawBuffersEXT field which is not available in any tagged release of glslang. The field is added in glslang in https://github.com/KhronosGroup/glslang/commit/e05cc20ec20a154d94256c744a3837c23719c0f9
+
+---
+diff --git b/libshaderc_util/src/resources.cc a/libshaderc_util/src/resources.cc
+index d64e47f..458a63f 100644
+--- b/libshaderc_util/src/resources.cc
++++ a/libshaderc_util/src/resources.cc
+@@ -125,7 +125,7 @@ const TBuiltInResource kDefaultTBuiltInResource = {
+ /* .maxTaskWorkGroupSizeY_NV = */ 1,
+ /* .maxTaskWorkGroupSizeZ_NV = */ 1,
+ /* .maxMeshViewCountNV = */ 4,
+- /* .maxDualSourceDrawBuffersEXT = */ 1,
++
+ // This is the glslang TLimits structure.
+ // It defines whether or not the following features are enabled.
+ // We want them to all be enabled.
+--
diff --git a/media-libs/shaderc/shaderc-2020.1.ebuild b/media-libs/shaderc/shaderc-2020.1.ebuild
new file mode 100644
index 000000000000..747ae7fac6b3
--- /dev/null
+++ b/media-libs/shaderc/shaderc-2020.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="Collection of tools, libraries and tests for shader compilation"
+HOMEPAGE="https://github.com/google/shaderc"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-util/glslang-8.13.3560_pre20200404[${MULTILIB_USEDEP}]
+ >=dev-util/spirv-tools-2020.3[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/spirv-headers-1.5.3
+ doc? ( dev-ruby/asciidoctor )
+ test? (
+ dev-cpp/gtest
+ $(python_gen_any_dep 'dev-python/nose[${PYTHON_USEDEP}]')
+ )
+"
+
+# https://github.com/google/shaderc/issues/470
+RESTRICT=test
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build.patch
+)
+
+python_check_deps() {
+ if use test; then
+ has_version --host-root "dev-python/nose[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_prepare() {
+ cmake_comment_add_subdirectory examples
+
+ # Unbundle glslang, spirv-headers, spirv-tools
+ cmake_comment_add_subdirectory third_party
+ sed -i \
+ -e "s|\$<TARGET_FILE:spirv-dis>|${EPREFIX}/usr/bin/spirv-dis|" \
+ glslc/test/CMakeLists.txt || die
+
+ # Disable git versioning
+ sed -i -e '/build-version/d' glslc/CMakeLists.txt || die
+
+ # Manually create build-version.inc as we disabled git versioning
+ cat <<- EOF > glslc/src/build-version.inc || die
+ "${P}\n"
+ "$(best_version dev-util/spirv-tools)\n"
+ "$(best_version dev-util/glslang)\n"
+ EOF
+
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DSHADERC_SKIP_TESTS="$(usex !test)"
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi && use doc; then
+ cmake-utils_src_make glslc_doc_README
+ fi
+ cmake-utils_src_compile
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ use doc && local HTML_DOCS=( "${BUILD_DIR}/glslc/README.html" )
+ fi
+ cmake-utils_src_install
+}