summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-11 13:47:30 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-11 14:21:28 +0100
commite59538996e8ee6730b3c2c2098b8640eb5213afc (patch)
treed0da87c554e77c45b5ec92d27dd55212a746e78f /media-libs
parentsys-apps/sandbox: Restore keywords; drop obsolete pch handling (diff)
downloadgentoo-e59538996e8ee6730b3c2c2098b8640eb5213afc.tar.gz
gentoo-e59538996e8ee6730b3c2c2098b8640eb5213afc.tar.bz2
gentoo-e59538996e8ee6730b3c2c2098b8640eb5213afc.zip
media-libs/portaudio: Revbump to add audacity-portmixer patch
taken from Debian. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/portaudio/Manifest1
-rw-r--r--media-libs/portaudio/portaudio-19.06.00-r2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/media-libs/portaudio/Manifest b/media-libs/portaudio/Manifest
index bd60a57b407f..7e5edf9ec299 100644
--- a/media-libs/portaudio/Manifest
+++ b/media-libs/portaudio/Manifest
@@ -1 +1,2 @@
DIST pa_stable_v190600_20161030.tgz 1450572 BLAKE2B 3cd63cca55ff222f452d306a1ab9035739545f48dbc9bc58196052cb51e518d86568059c7528533a6932c39c68d1a5210e06470a16343b92c7e4132b71cc552e SHA512 7ec692cbd8c23878b029fad9d9fd63a021f57e60c4921f602995a2fca070c29f17a280c7f2da5966c4aad29d28434538452f4c822eacf3a60af59a6dc8e9704c
+DIST portaudio-19.06.00-audacity-portmixer.patch 8722 BLAKE2B 2b69bcf26e55be46d354dc44756fd03b16031fa86a334b776eb4326a4c64a7e22abd6bf60794847526102391c8e65813b41338cf94c647e3e9b68d82ea5dc5f5 SHA512 f693aef477b516c7a03eb021260cbecb23200422a927a117e3e59a1b4e6c6c2983fbea8ee3a3714ebc55728933654bd7909327a0bab4450ccf4e6a02c86a63b5
diff --git a/media-libs/portaudio/portaudio-19.06.00-r2.ebuild b/media-libs/portaudio/portaudio-19.06.00-r2.ebuild
new file mode 100644
index 000000000000..42b46a16acc5
--- /dev/null
+++ b/media-libs/portaudio/portaudio-19.06.00-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal
+
+DESCRIPTION="A free, cross-platform, open-source, audio I/O library"
+HOMEPAGE="http://www.portaudio.com/"
+SRC_URI="http://www.portaudio.com/archives/pa_stable_v190600_20161030.tgz
+ https://sources.debian.org/data/main/p/portaudio19/19.6.0-1/debian/patches/audacity-portmixer.patch -> ${PN}-19.06.00-audacity-portmixer.patch"
+
+LICENSE="MIT"
+SLOT="0"
+kEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="alsa +cxx debug doc jack oss static-libs"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+DOCS=( README.txt )
+
+PATCHES=(
+ "${DISTDIR}/${PN}-19.06.00-audacity-portmixer.patch"
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable cxx)
+ $(use_enable static-libs static)
+ $(use_with alsa)
+ $(use_with jack)
+ $(use_with oss)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ # workaround parallel build issue
+ emake lib/libportaudio.la
+ emake
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+
+ if use doc; then
+ doxygen -u Doxyfile || die
+ doxygen Doxyfile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ use doc && dodoc -r doc/html
+ find "${ED}" -name "*.la" -delete || die
+}