summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-31 09:00:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-31 11:10:20 +0200
commitec9839f0030c73681feab619b9ec42282e6dda84 (patch)
treed1463f169b4f8715cec7732945cdbe93c282cd31 /media-libs
parentmedia-libs/libdc1394: bump to 2.2.6 (diff)
downloadgentoo-ec9839f0030c73681feab619b9ec42282e6dda84.tar.gz
gentoo-ec9839f0030c73681feab619b9ec42282e6dda84.tar.bz2
gentoo-ec9839f0030c73681feab619b9ec42282e6dda84.zip
media-libs/zimg: bump to 3.0.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/zimg/Manifest1
-rw-r--r--media-libs/zimg/zimg-3.0.1.ebuild32
-rw-r--r--media-libs/zimg/zimg-9999.ebuild5
3 files changed, 35 insertions, 3 deletions
diff --git a/media-libs/zimg/Manifest b/media-libs/zimg/Manifest
index 33a55d77fd70..40197e8b8fc8 100644
--- a/media-libs/zimg/Manifest
+++ b/media-libs/zimg/Manifest
@@ -1,2 +1,3 @@
DIST zimg-2.8.tar.gz 265363 BLAKE2B a8982c64325e0089617136fcd5d6ee429ab861e3b9445b9cc0292bd3bbd3abb5783e94983e3e802fd9e59c2c7089eeea176d1eda4f3a850379cfc4fb36cbc408 SHA512 1e89087a756798a7ae3bfae3bc8244b29ae8ae7f04f53bdf6c4d4de3cb11412dc1eecd95a4a121bb9077437e633f8fbb665522ff8112ade806d9191ea4b5f7bf
DIST zimg-2.9.2.tar.gz 266049 BLAKE2B 214a6afec061dc7cc7c751f2a57e56951e44b78fea6a0c0dc71235d3dd286fb811303b0a5198ab82165ee78d993caabaf39d7ec17db4c4e5ffca9a3475b49781 SHA512 b688f8e93a2e4549f2c844cd58c6e0714e6494d6fc8c800dc1b0cdf2278fb9925a646fc332350c1b5d77cef2134bf35e18a873c24ea1979c1adce57bfef68ebe
+DIST zimg-3.0.1.tar.gz 326304 BLAKE2B 353e623520df49122badd2d58400936fd25bf74fe386ade6b7a5c1b86db696dd50ff72ff40e1edbd38ee9a8a10dd429f207061fdb2ea326018396dfb92707053 SHA512 ae117399772d2c35ffa61b8cf5d156edf4ed65e9ffeb2e9e0688c88244fdd1a89c098bd842e3795b33fb0951da97f844fb6ffe27045e3234720f70f842356936
diff --git a/media-libs/zimg/zimg-3.0.1.ebuild b/media-libs/zimg/zimg-3.0.1.ebuild
new file mode 100644
index 000000000000..306320548ba3
--- /dev/null
+++ b/media-libs/zimg/zimg-3.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="debug static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
diff --git a/media-libs/zimg/zimg-9999.ebuild b/media-libs/zimg/zimg-9999.ebuild
index 4e92e0eec814..306320548ba3 100644
--- a/media-libs/zimg/zimg-9999.ebuild
+++ b/media-libs/zimg/zimg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ HOMEPAGE="https://github.com/sekrit-twc/zimg"
LICENSE="WTFPL-2"
SLOT="0"
-IUSE="cpu_flags_x86_sse debug static-libs"
+IUSE="debug static-libs"
src_prepare() {
default
@@ -28,6 +28,5 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable debug) \
- $(use_enable cpu_flags_x86_sse x86simd) \
$(use_enable static-libs static)
}