summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-31 09:49:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-31 11:10:21 +0200
commiteecac3800448796f07fac87e8226fa6287f7f972 (patch)
treea6b89e026e1141790b15b6c8c49635edd175600c /media-libs
parentmedia-libs/nv-codec-headers: bump to 10.0.26.0 (diff)
downloadgentoo-eecac3800448796f07fac87e8226fa6287f7f972.tar.gz
gentoo-eecac3800448796f07fac87e8226fa6287f7f972.tar.bz2
gentoo-eecac3800448796f07fac87e8226fa6287f7f972.zip
media-libs/libsndfile: bump to 1.0.29
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsndfile/Manifest1
-rw-r--r--media-libs/libsndfile/libsndfile-1.0.29.ebuild74
-rw-r--r--media-libs/libsndfile/libsndfile-9999.ebuild3
3 files changed, 77 insertions, 1 deletions
diff --git a/media-libs/libsndfile/Manifest b/media-libs/libsndfile/Manifest
index b425c3f223a3..8184da2f4f31 100644
--- a/media-libs/libsndfile/Manifest
+++ b/media-libs/libsndfile/Manifest
@@ -1,2 +1,3 @@
DIST libsndfile-1.0.28.tar.gz 1202833 BLAKE2B 102735766e2c22b5278fde43feaaa664598c08fadb5264d5130e4bf1e354bd4202948db38e2912d7487bd7f8c0b9faf1616c0873eed886a56b1d7f49452bf488 SHA512 890731a6b8173f714155ce05eaf6d991b31632c8ab207fbae860968861a107552df26fcf85602df2e7f65502c7256c1b41735e1122485a3a07ddb580aa83b57f
+DIST libsndfile-1.0.29.tar.bz2 831090 BLAKE2B 0bdf20a0abe22f628434e80c61c6b7d31e62c40dd881f462d8e12eb4488f0bcb1c0c7712fbff4902bbbea86e08763a01f7d85b875166c5c9214ab9d8aa10a1c1 SHA512 72cf038b26c66e6e085d97ef1954bd3aa76315527f632649707c76128953bfbb2c9b52527d309720ca1107a9e04e033722995911dad43b4adda46bf4a05354d7
DIST libsndfile-1.0.29_pre2_p20191024.tar.gz 720981 BLAKE2B 9f1dcf3d3669b66d8582d50b62ff863facd7125432a84a3e1e3fb0f817554f260f42948b4479371fb0967dcc75bedc6c49afffc6bee3f973a875d72d2e508210 SHA512 e37b385b90cadc97348db03b6c5ae7a8fcee17ded60f54d1508adddb8e2dc604ea44b60a0fe08627e81c0faa83997cdafb0b0ecf8574f901bf5e8a1819a63998
diff --git a/media-libs/libsndfile/libsndfile-1.0.29.ebuild b/media-libs/libsndfile/libsndfile-1.0.29.ebuild
new file mode 100644
index 000000000000..d975b6e02701
--- /dev/null
+++ b/media-libs/libsndfile/libsndfile-1.0.29.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/erikd/libsndfile.git"
+else
+ SRC_URI="https://github.com/erikd/libsndfile/releases/download/v${PV}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+inherit python-any-r1 multilib-minimal
+
+DESCRIPTION="C library for reading and writing files containing sampled sound"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="alsa minimal sqlite static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !minimal? (
+ >=media-libs/flac-1.2.1-r5:=[${MULTILIB_USEDEP}]
+ >=media-libs/libogg-1.3.0:=[${MULTILIB_USEDEP}]
+ >=media-libs/libvorbis-1.3.3-r1:=[${MULTILIB_USEDEP}]
+ >=media-libs/opus-1.1:=[${MULTILIB_USEDEP}]
+ )
+ alsa? ( media-libs/alsa-lib:= )
+ sqlite? ( >=dev-db/sqlite-3.2 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )"
+if [[ ${PV} == *9999 ]]; then
+ BDEPEND+="
+ ${PYTHON_DEPS}
+ sys-devel/autogen
+ "
+fi
+
+pkg_setup() {
+ if use test || [[ ${PV} == *9999 ]]; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-octave \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ $(use_enable !minimal external-libs) \
+ $(multilib_native_enable full-suite) \
+ $(multilib_native_use_enable alsa) \
+ $(multilib_native_use_enable sqlite) \
+ PYTHON="${EPYTHON}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libsndfile/libsndfile-9999.ebuild b/media-libs/libsndfile/libsndfile-9999.ebuild
index b5b4cddaa034..d975b6e02701 100644
--- a/media-libs/libsndfile/libsndfile-9999.ebuild
+++ b/media-libs/libsndfile/libsndfile-9999.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/erikd/libsndfile.git"
else
- SRC_URI="http://www.mega-nerd.com/libsndfile/files/${P}.tar.gz"
+ SRC_URI="https://github.com/erikd/libsndfile/releases/download/v${PV}/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
inherit python-any-r1 multilib-minimal
@@ -57,6 +57,7 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
--disable-octave \
+ --disable-werror \
$(use_enable static-libs static) \
$(use_enable !minimal external-libs) \
$(multilib_native_enable full-suite) \