summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-26 18:44:17 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-26 19:20:34 +0100
commitf080b7b78a665b0762431e84927786b557468454 (patch)
treec341473ca68dae5d1c62ceea67c87c22a0200858 /media-libs
parentmedia-plugins/gst-plugins-x265: version bump to 1.6.2 (diff)
downloadgentoo-f080b7b78a665b0762431e84927786b557468454.tar.gz
gentoo-f080b7b78a665b0762431e84927786b557468454.tar.bz2
gentoo-f080b7b78a665b0762431e84927786b557468454.zip
media-libs/gst-plugins-ugly version bump to 1.6.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-ugly/Manifest1
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/Manifest b/media-libs/gst-plugins-ugly/Manifest
index 56e8f9d51d7f..dd31d2e8c60f 100644
--- a/media-libs/gst-plugins-ugly/Manifest
+++ b/media-libs/gst-plugins-ugly/Manifest
@@ -1,3 +1,4 @@
DIST gst-plugins-ugly-0.10.19.tar.xz 882452 SHA256 4934f65ff892637e7efaf1cfe635779189dde429d0706f40c86a3aac476ea873 SHA512 16d030998142f698f8ab7dbe55c0c6c8db05ade6b3c007a3aacb5491592e8c60e0a9d62f1a840eab4d57825b1beb9017e3f68f5a90288435216586d67040deda WHIRLPOOL f72f224c5f486982370e9d264ad7c658324783b42e995eef759faf270a18d8f12261d90ac6e70af38579921b0970f7aba50c6d091edcd6dc3dda272bcbef755f
DIST gst-plugins-ugly-1.4.5.tar.xz 846828 SHA256 5cd5e81cf618944f4dc935f1669b2125e8bb2fe9cc7dc8dc15b72237aca49067 SHA512 9353a5b9492758d8255fcab23c0eb170ec31e884774c22915b57cc4a2ed56bad61643d7bd44fcdb919e7ad9b2023d1d0fab23f9c9fda1cb2b9883c92ec6b6fc0 WHIRLPOOL b212a4dcba654dac7866ad75551b26818349780b0d7905e63c45b75e21ffbb86ae0f4e9e79ef8bfb317149c2d4f01cbda2c6e2cf2cbcf58991bc09ba9aa85f4e
DIST gst-plugins-ugly-1.6.1.tar.xz 859200 SHA256 0cc3f90e4322efe1f774272e8fe5c185be37cf7999cd5ca7e0e0607e03d56a57 SHA512 f62eb68779b6bbcc555f43c7c9f4a034f0fabe9244161d9c5ffd410c64a56c915637f5d4ec974810acd67fc744b9a143ba46b6ace96daa2ab56703b1e954c2a0 WHIRLPOOL 8bf8d4295054b8346c08794bddf081da668cd6d9e0e3320381fd2f3a52eb8ffbfa12e0a847137a7cde94de51ebf3bcecee17a098581d63ce444d52a42af76264
+DIST gst-plugins-ugly-1.6.2.tar.xz 859400 SHA256 e7f1b6321c8667fabc0dedce3998a3c6e90ce9ce9dea7186d33dc4359f9e9845 SHA512 b8354bce9b0d8f46d16e18c766e8f432d029cfd13cb0141d54aaef73906072a2ccd72ecfc0a566da9c909f7d9b2a8bfa3e2d45a7c5a22a43fb8f811f75f2f173 WHIRLPOOL 75ad5ee7fdae1e2a899873d70e737f15c996a73f5beb93be740c436a855640b60f600cc68bf341be769f42dd4c077f3f04036212feed598a4405cc3ac3140fdb
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.2.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.2.ebuild
new file mode 100644
index 000000000000..186d14d6f079
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}