summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-11-17 19:45:59 +0200
committerMart Raudsepp <leio@gentoo.org>2019-11-17 19:51:21 +0200
commitf87e81997e158c6fed35169a281f88b4385c509a (patch)
tree2e74f6800f71e9b86b0de0eafdc359721a0bee55 /media-libs
parentdev-python/flask-htmlmin: Bump to 1.5.2 (diff)
downloadgentoo-f87e81997e158c6fed35169a281f88b4385c509a.tar.gz
gentoo-f87e81997e158c6fed35169a281f88b4385c509a.tar.bz2
gentoo-f87e81997e158c6fed35169a281f88b4385c509a.zip
media-libs/cogl: drop unnecessary test deps with tests restricted
Bug: https://bugs.gentoo.org/692212 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cogl/cogl-1.22.2.ebuild39
-rw-r--r--media-libs/cogl/cogl-1.22.4.ebuild37
2 files changed, 23 insertions, 53 deletions
diff --git a/media-libs/cogl/cogl-1.22.2.ebuild b/media-libs/cogl/cogl-1.22.2.ebuild
index 0a029d23e07a..c3702f70decd 100644
--- a/media-libs/cogl/cogl-1.22.2.ebuild
+++ b/media-libs/cogl/cogl-1.22.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit gnome2 multilib virtualx
+inherit gnome2 multilib
DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
HOMEPAGE="https://www.cogl3d.org/"
@@ -12,7 +12,7 @@ LICENSE="MIT BSD"
SLOT="1.0/20" # subslot = .so version
# doc and profile disable for now due to bugs #484750 and #483332
-IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango test wayland" # doc profile
+IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango wayland" # doc profile
REQUIRED_USE="
wayland? ( gles2 )
|| ( gles2 opengl )
@@ -52,9 +52,6 @@ DEPEND="${COMMON_DEPEND}
>=dev-util/gtk-doc-am-1.13
>=sys-devel/gettext-0.19
virtual/pkgconfig
- test? (
- app-eselect/eselect-opengl
- media-libs/mesa[classic] )
"
# Need classic mesa swrast for tests, llvmpipe causes a test failure
@@ -66,14 +63,14 @@ src_prepare() {
sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
-i Makefile.am Makefile.in || die
- if ! use test ; then
- # For some reason the configure switch will not completely disable
- # tests being built
- sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
- -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
- -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
- -i Makefile.am Makefile.in || die
- fi
+ #if ! use test ; then
+ # For some reason the configure switch will not completely disable
+ # tests being built
+ sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
+ -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
+ -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ #fi
gnome2_src_prepare
}
@@ -101,25 +98,13 @@ src_configure() {
$(use_enable introspection) \
$(use_enable kms kms-egl-platform) \
$(use_enable pango cogl-pango) \
- $(use_enable test unit-tests) \
+ --disable-unit-tests \
$(use_enable wayland wayland-egl-platform) \
$(use_enable wayland wayland-egl-server) \
--disable-profile
# $(use_enable profile)
}
-src_test() {
- # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
- # NOTE: recheck if this is needed after every mesa bump
- if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
- ewarn "Skipping tests because a binary OpenGL library is enabled. To"
- ewarn "run tests for ${PN}, you need to enable the Mesa library:"
- ewarn "# eselect opengl set xorg-x11"
- return
- fi
- virtx emake check LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa"
-}
-
src_install() {
if use examples; then
insinto /usr/share/doc/${PF}/examples
diff --git a/media-libs/cogl/cogl-1.22.4.ebuild b/media-libs/cogl/cogl-1.22.4.ebuild
index 7061df2b3cde..2191b69cd4aa 100644
--- a/media-libs/cogl/cogl-1.22.4.ebuild
+++ b/media-libs/cogl/cogl-1.22.4.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit gnome2 multilib virtualx
+inherit gnome2 multilib
DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
HOMEPAGE="https://www.cogl3d.org/"
@@ -12,7 +12,7 @@ LICENSE="MIT BSD"
SLOT="1.0/20" # subslot = .so version
# doc and profile disable for now due to bugs #484750 and #483332
-IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango test wayland" # doc profile
+IUSE="debug examples gles2 gstreamer +introspection +kms +opengl +pango wayland" # doc profile
REQUIRED_USE="
wayland? ( gles2 )
|| ( gles2 opengl )
@@ -52,9 +52,6 @@ DEPEND="${COMMON_DEPEND}
>=dev-util/gtk-doc-am-1.13
>=sys-devel/gettext-0.19
virtual/pkgconfig
- test? (
- app-eselect/eselect-opengl
- media-libs/mesa[classic] )
"
# Need classic mesa swrast for tests, llvmpipe causes a test failure
@@ -66,14 +63,14 @@ src_prepare() {
sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
-i Makefile.am Makefile.in || die
- if ! use test ; then
- # For some reason the configure switch will not completely disable
- # tests being built
- sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
- -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
- -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
- -i Makefile.am Makefile.in || die
- fi
+ #if ! use test ; then
+ # For some reason the configure switch will not completely disable
+ # tests being built
+ sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
+ -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
+ -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
+ -i Makefile.am Makefile.in || die
+ #fi
gnome2_src_prepare
}
@@ -101,25 +98,13 @@ src_configure() {
$(use_enable introspection) \
$(use_enable kms kms-egl-platform) \
$(use_enable pango cogl-pango) \
- $(use_enable test unit-tests) \
+ --disable-unit-tests \
$(use_enable wayland wayland-egl-platform) \
$(use_enable wayland wayland-egl-server) \
--disable-profile
# $(use_enable profile)
}
-src_test() {
- # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
- # NOTE: recheck if this is needed after every mesa bump
- if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
- ewarn "Skipping tests because a binary OpenGL library is enabled. To"
- ewarn "run tests for ${PN}, you need to enable the Mesa library:"
- ewarn "# eselect opengl set xorg-x11"
- return
- fi
- virtx emake check LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa"
-}
-
src_install() {
if use examples; then
insinto /usr/share/doc/${PF}/examples