summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/banshee-community-extensions
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/banshee-community-extensions')
-rw-r--r--media-plugins/banshee-community-extensions/Manifest2
-rw-r--r--media-plugins/banshee-community-extensions/banshee-community-extensions-2.2.0.ebuild79
-rw-r--r--media-plugins/banshee-community-extensions/banshee-community-extensions-2.4.0-r1.ebuild84
-rw-r--r--media-plugins/banshee-community-extensions/banshee-community-extensions-2.4.0.ebuild80
-rw-r--r--media-plugins/banshee-community-extensions/metadata.xml19
5 files changed, 264 insertions, 0 deletions
diff --git a/media-plugins/banshee-community-extensions/Manifest b/media-plugins/banshee-community-extensions/Manifest
new file mode 100644
index 000000000000..da769d9a0197
--- /dev/null
+++ b/media-plugins/banshee-community-extensions/Manifest
@@ -0,0 +1,2 @@
+DIST banshee-community-extensions-2.2.0.tar.bz2 858373 SHA256 3ac0c7e9e00b8ab7b91a8942cb5b1fc360977b15ec303756d4a440704a22bb15 SHA512 7b130d69639bd9fca28d5320abf7c742e687ecf049711ac68230355a85faa5570ba349e6163ca982e9b24519e2224e1f2fb07ca6686cbf1c73a7e3cccf2e0598 WHIRLPOOL e5898414f75321847c6c487a3d8b3282fde77a6dc7c74812b75428266b8ea44c1510ad25e9521a96d531ea4c71bc52f367aed44d5b8448c86ea42144281e5d72
+DIST banshee-community-extensions-2.4.0.tar.bz2 892287 SHA256 6f20404de80090bb5d88a57c043e876a192f480ac3488ce7697344f1447d48b3 SHA512 fbaad9ede79fc2ae6ddccd3799e465ea9d0fc08251cca7be5a7eebe041b3b71d788bb767e070737c2d7c8ddeffcd196bc353d37c30489f1a77c6d9c2e2c991da WHIRLPOOL d8ba009ccbd1c8192ca3ec333a271f4f40205ed514fc7fd9c0a64ef43a3a96b923d5ffc7d175eee994f6e713f99e57670e7659a95a31205a2eed10b6be407400
diff --git a/media-plugins/banshee-community-extensions/banshee-community-extensions-2.2.0.ebuild b/media-plugins/banshee-community-extensions/banshee-community-extensions-2.2.0.ebuild
new file mode 100644
index 000000000000..e9730b42f009
--- /dev/null
+++ b/media-plugins/banshee-community-extensions/banshee-community-extensions-2.2.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base mono
+
+DESCRIPTION="Community-developed plugins for the Banshee media player"
+HOMEPAGE="http://banshee.fm/"
+SRC_URI="http://download.banshee-project.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc lastfmfingerprint lirc lyrics mirage telepathy"
+
+DEPEND=">=dev-lang/mono-2.0
+ >=media-sound/banshee-2.1.0[web]
+ >=gnome-base/gconf-2.0
+ dev-dotnet/gconf-sharp:2
+ doc? ( >=app-text/gnome-doc-utils-0.17.3 )
+ lastfmfingerprint? (
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate
+ )
+ lirc? ( app-misc/lirc )
+ mirage? (
+ dev-libs/glib:2
+ dev-db/sqlite:3
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate
+ >=media-libs/gstreamer-0.10.15:0.10
+ >=media-libs/gst-plugins-base-0.10.15:0.10
+ )
+ telepathy? (
+ dev-dotnet/notify-sharp
+ >=dev-lang/mono-2.4.2
+ )"
+RDEPEND="${DEPEND}
+ !media-plugins/banshee-lyrics
+ !media-plugins/banshee-mirage"
+
+src_configure() {
+ # Disable ClutterFlow as we don't have clutter-sharp and co in tree
+ # Disable UbuntuOneMusicStore as we don't have ubuntuone-sharp
+ # Disable AppIndicator as it's not in tree
+ # Disable OpenVP as some of its dependencies are not in the tree
+ # Disable SoundMenu as it requires indicate-sharp
+ # Disable zeitgeistdataprovider as it requires zeitgeist-sharp
+ local myconf="--enable-gnome
+ --disable-static
+ --enable-release
+ --disable-maintainer-mode
+ --with-gconf-schema-file-dir=/etc/gconf/schemas
+ --with-vendor-build-id=Gentoo/${PN}/${PVR}
+ --disable-scrollkeeper
+ --disable-clutterflow --disable-appindicator --disable-openvp
+ --disable-zeitgeistdataprovider
+ --enable-ampache --enable-karaoke --enable-jamendo
+ --enable-randombylastfm --enable-albumartwriter
+ --enable-duplicatesongdetector"
+
+ econf \
+ $(use_enable doc user-help) \
+ $(use_enable lastfmfingerprint) \
+ $(use_enable lirc) \
+ $(use_enable lyrics) \
+ $(use_enable mirage) \
+ $(use_enable telepathy) \
+ $(use_enable test tests) \
+ ${myconf}
+}
+
+src_install() {
+ base_src_install
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+ dodoc AUTHORS NEWS README
+}
diff --git a/media-plugins/banshee-community-extensions/banshee-community-extensions-2.4.0-r1.ebuild b/media-plugins/banshee-community-extensions/banshee-community-extensions-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..3917e663534c
--- /dev/null
+++ b/media-plugins/banshee-community-extensions/banshee-community-extensions-2.4.0-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base mono
+
+DESCRIPTION="Community-developed plugins for the Banshee media player"
+HOMEPAGE="http://banshee.fm/download/extensions/"
+SRC_URI="http://download.banshee-project.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc lastfmfingerprint lirc lyrics mirage telepathy zeitgeist"
+
+DEPEND=">=dev-lang/mono-2.0
+ >=media-sound/banshee-2.4.0[web]
+ >=gnome-base/gconf-2.0
+ dev-dotnet/gconf-sharp:2
+ doc? ( >=app-text/gnome-doc-utils-0.17.3 )
+ lastfmfingerprint? (
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate
+ )
+ lirc? ( app-misc/lirc )
+ mirage? (
+ dev-libs/glib:2
+ dev-db/sqlite:3
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate
+ >=media-libs/gstreamer-0.10.15:0.10
+ >=media-libs/gst-plugins-base-0.10.15:0.10
+ )
+ telepathy? (
+ dev-dotnet/notify-sharp
+ >=dev-lang/mono-2.4.2
+ )
+ zeitgeist? (
+ dev-libs/libzeitgeist
+ dev-dotnet/zeitgeist-sharp
+ )"
+RDEPEND="${DEPEND}
+ !media-plugins/banshee-lyrics
+ !media-plugins/banshee-mirage"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ # Disable ClutterFlow as we don't have clutter-sharp and co in tree
+ # Disable UbuntuOneMusicStore as we don't have ubuntuone-sharp
+ # Disable AppIndicator as it's not in tree
+ # Disable OpenVP as some of its dependencies are not in the tree
+ # Disable SoundMenu as it requires indicate-sharp
+ # Disable zeitgeistdataprovider as it requires zeitgeist-sharp
+ local myconf="--enable-gnome
+ --disable-static
+ --enable-release
+ --disable-maintainer-mode
+ --with-gconf-schema-file-dir=/etc/gconf/schemas
+ --with-vendor-build-id=Gentoo/${PN}/${PVR}
+ --disable-scrollkeeper
+ --disable-clutterflow --disable-appindicator --disable-openvp
+ --enable-ampache --enable-karaoke --enable-jamendo
+ --enable-randombylastfm --enable-albumartwriter
+ --enable-duplicatesongdetector --enable-foldersync"
+
+ econf \
+ $(use_enable doc user-help) \
+ $(use_enable lastfmfingerprint) \
+ $(use_enable lirc) \
+ $(use_enable lyrics) \
+ $(use_enable mirage) \
+ $(use_enable telepathy) \
+ $(use_enable zeitgeist zeitgeistdataprovider) \
+ $(use_enable test tests) \
+ ${myconf}
+}
+
+src_install() {
+ base_src_install
+ prune_libtool_files --all
+}
diff --git a/media-plugins/banshee-community-extensions/banshee-community-extensions-2.4.0.ebuild b/media-plugins/banshee-community-extensions/banshee-community-extensions-2.4.0.ebuild
new file mode 100644
index 000000000000..a7a50986fcdd
--- /dev/null
+++ b/media-plugins/banshee-community-extensions/banshee-community-extensions-2.4.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base mono
+
+DESCRIPTION="Community-developed plugins for the Banshee media player"
+HOMEPAGE="http://banshee.fm/download/extensions/"
+SRC_URI="http://download.banshee-project.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc lastfmfingerprint lirc lyrics mirage telepathy"
+
+DEPEND=">=dev-lang/mono-2.0
+ >=media-sound/banshee-2.4.0[web]
+ >=gnome-base/gconf-2.0
+ dev-dotnet/gconf-sharp:2
+ doc? ( >=app-text/gnome-doc-utils-0.17.3 )
+ lastfmfingerprint? (
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate
+ )
+ lirc? ( app-misc/lirc )
+ mirage? (
+ dev-libs/glib:2
+ dev-db/sqlite:3
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate
+ >=media-libs/gstreamer-0.10.15:0.10
+ >=media-libs/gst-plugins-base-0.10.15:0.10
+ )
+ telepathy? (
+ dev-dotnet/notify-sharp
+ >=dev-lang/mono-2.4.2
+ )"
+RDEPEND="${DEPEND}
+ !media-plugins/banshee-lyrics
+ !media-plugins/banshee-mirage"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ # Disable ClutterFlow as we don't have clutter-sharp and co in tree
+ # Disable UbuntuOneMusicStore as we don't have ubuntuone-sharp
+ # Disable AppIndicator as it's not in tree
+ # Disable OpenVP as some of its dependencies are not in the tree
+ # Disable SoundMenu as it requires indicate-sharp
+ # Disable zeitgeistdataprovider as it requires zeitgeist-sharp
+ local myconf="--enable-gnome
+ --disable-static
+ --enable-release
+ --disable-maintainer-mode
+ --with-gconf-schema-file-dir=/etc/gconf/schemas
+ --with-vendor-build-id=Gentoo/${PN}/${PVR}
+ --disable-scrollkeeper
+ --disable-clutterflow --disable-appindicator --disable-openvp
+ --enable-ampache --enable-karaoke --enable-jamendo
+ --enable-randombylastfm --enable-albumartwriter
+ --enable-duplicatesongdetector --enable-foldersync"
+
+ econf \
+ $(use_enable doc user-help) \
+ $(use_enable lastfmfingerprint) \
+ $(use_enable lirc) \
+ $(use_enable lyrics) \
+ $(use_enable mirage) \
+ $(use_enable telepathy) \
+ --disable-zeitgeistdataprovider \
+ $(use_enable test tests) \
+ ${myconf}
+}
+
+src_install() {
+ base_src_install
+ prune_libtool_files --all
+}
diff --git a/media-plugins/banshee-community-extensions/metadata.xml b/media-plugins/banshee-community-extensions/metadata.xml
new file mode 100644
index 000000000000..ceff0fb2ab2a
--- /dev/null
+++ b/media-plugins/banshee-community-extensions/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <herd>gstreamer</herd>
+ <use>
+ <flag name="lastfmfingerprint">Enable support to ientify your
+ music automatically, using the Last.fm online service.</flag>
+ <flag name="lirc">Enable the remote control plugin (uses
+ <pkg>app-misc/lirc</pkg>)</flag>
+ <flag name="lyrics">Enable support for automatically fetching
+ lyrics</flag>
+ <flag name="mirage">Enable the Mirage plugin which automatically, and
+ intelligently generates playlists for you</flag>
+ <flag name="telepathy">Enables the Telepathy plugin which lets you to
+ share and stream music with IM buddies</flag>
+ <flag name="zeitgeist">Build the plugin to inject events to <pkg>gnome-extra/zeitgeist</pkg></flag>
+ </use>
+</pkgmetadata>