summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-19 19:26:02 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-20 17:18:18 -0600
commitf7b6aee77f1f9b16319977ced0c99445030a1c19 (patch)
treeff3c47ec6147f6bbb1e1e2234099bddd076bcc2d /media-plugins/calf/calf-9999.ebuild
parentsys-cluster/nova: 16.0.4 bup (diff)
downloadgentoo-f7b6aee77f1f9b16319977ced0c99445030a1c19.tar.gz
gentoo-f7b6aee77f1f9b16319977ced0c99445030a1c19.tar.bz2
gentoo-f7b6aee77f1f9b16319977ced0c99445030a1c19.zip
media-plugins/calf: 0.90.0 bump
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'media-plugins/calf/calf-9999.ebuild')
-rw-r--r--media-plugins/calf/calf-9999.ebuild40
1 files changed, 24 insertions, 16 deletions
diff --git a/media-plugins/calf/calf-9999.ebuild b/media-plugins/calf/calf-9999.ebuild
index 333c1172872f..37d406d695bb 100644
--- a/media-plugins/calf/calf-9999.ebuild
+++ b/media-plugins/calf/calf-9999.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-AUTOTOOLS_AUTORECONF=yes
-inherit autotools-utils
+EAPI=6
+inherit autotools
DESCRIPTION="A set of open source instruments and effects for digital audio workstations"
HOMEPAGE="http://calf-studio-gear.org/"
@@ -18,29 +17,38 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="lash lv2 static-libs experimental"
+IUSE="cpu_flags_x86_sse gtk jack lash lv2 static-libs experimental"
RDEPEND="dev-libs/atk
dev-libs/expat
dev-libs/glib:2
- gnome-base/libglade:2.0
media-sound/fluidsynth
- virtual/jack
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
- x11-libs/pango
+ jack? ( virtual/jack )
+ gtk? (
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf
+ x11-libs/pango
+ )
lash? ( media-sound/lash )
lv2? ( media-libs/lv2 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
- myeconfargs=(
- --with-lv2-dir=/usr/$(get_libdir)/lv2
- $(use_with lash)
- $(use_with lv2)
+ # automagic...
+ #$(use_with gtk gui)
+ #$(use_with jack)
+ econf \
+ $(use_with lash) \
+ $(use_with lv2 lv2) \
+ $(use_with lv2 lv2-dir /usr/$(get_libdir)/lv2) \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse sse) \
$(use_enable experimental)
- )
- autotools-utils_src_configure
}