summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/calf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/calf')
-rw-r--r--media-plugins/calf/Manifest1
-rw-r--r--media-plugins/calf/calf-0.0.60.ebuild46
-rw-r--r--media-plugins/calf/calf-9999.ebuild46
-rw-r--r--media-plugins/calf/metadata.xml11
4 files changed, 104 insertions, 0 deletions
diff --git a/media-plugins/calf/Manifest b/media-plugins/calf/Manifest
new file mode 100644
index 000000000000..65b6ac7ff478
--- /dev/null
+++ b/media-plugins/calf/Manifest
@@ -0,0 +1 @@
+DIST calf-0.0.60.tar.gz 5594386 SHA256 5ca8d3c8fbdca52304cbd01d80eebc0e2adf6bc6404a05a5fc58a0f5512c8100 SHA512 85a814b1210765bd16a60a4921c4518b1721c6b72aa9c902d1c0f8e4dcad285de2b52e3c2783bc221b575c61de9c859f40d589cf8a68efc260f393a864dfc360 WHIRLPOOL 4cf931e1f6bddf4b4b53cd2d18f61c400fdf8c2137507f3623414bdd39980502163eb4cebcac953d9ab38e5571cbaf9de54e6c7cb25bfb61e59e2d0efbc5b692
diff --git a/media-plugins/calf/calf-0.0.60.ebuild b/media-plugins/calf/calf-0.0.60.ebuild
new file mode 100644
index 000000000000..3a0b8061f503
--- /dev/null
+++ b/media-plugins/calf/calf-0.0.60.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils
+
+DESCRIPTION="A set of open source instruments and effects for digital audio workstations"
+HOMEPAGE="http://calf-studio-gear.org/"
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/calf-studio-gear/calf.git"
+else
+ SRC_URI="https://github.com/calf-studio-gear/calf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="lash lv2 static-libs"
+
+RDEPEND="dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ media-sound/fluidsynth
+ media-sound/jack-audio-connection-kit
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ lash? ( media-sound/lash )
+ lv2? ( media-libs/lv2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myeconfargs=(
+ --with-lv2-dir=/usr/$(get_libdir)/lv2
+ $(use_with lash)
+ $(use_with lv2)
+ )
+ autotools-utils_src_configure
+}
diff --git a/media-plugins/calf/calf-9999.ebuild b/media-plugins/calf/calf-9999.ebuild
new file mode 100644
index 000000000000..3a0b8061f503
--- /dev/null
+++ b/media-plugins/calf/calf-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils
+
+DESCRIPTION="A set of open source instruments and effects for digital audio workstations"
+HOMEPAGE="http://calf-studio-gear.org/"
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/calf-studio-gear/calf.git"
+else
+ SRC_URI="https://github.com/calf-studio-gear/calf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="lash lv2 static-libs"
+
+RDEPEND="dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ media-sound/fluidsynth
+ media-sound/jack-audio-connection-kit
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ lash? ( media-sound/lash )
+ lv2? ( media-libs/lv2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myeconfargs=(
+ --with-lv2-dir=/usr/$(get_libdir)/lv2
+ $(use_with lash)
+ $(use_with lv2)
+ )
+ autotools-utils_src_configure
+}
diff --git a/media-plugins/calf/metadata.xml b/media-plugins/calf/metadata.xml
new file mode 100644
index 000000000000..7e7647c57c5a
--- /dev/null
+++ b/media-plugins/calf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+ <use>
+ <flag name="lv2">Add support for Ladspa V2</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">calf-studio-gear/calf</remote-id>
+ </upstream>
+</pkgmetadata>