summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandra Parker <alex.iris.parker@gmail.com>2020-10-07 18:27:33 +0000
committerSam James <sam@gentoo.org>2020-10-07 18:46:05 +0000
commitf2e63030ebfbcf3efea6a9a4bffe40acb4df454f (patch)
tree7f2d8e5f75e90bffd9770d608f4d99e430b449b6 /media-plugins/gimp-lqr
parentmedia-plugins/gimp-lqr: port to EAPI 7 (diff)
downloadgentoo-f2e63030ebfbcf3efea6a9a4bffe40acb4df454f.tar.gz
gentoo-f2e63030ebfbcf3efea6a9a4bffe40acb4df454f.tar.bz2
gentoo-f2e63030ebfbcf3efea6a9a4bffe40acb4df454f.zip
media-plugins/gimp-lqr: fix GCC 10 (-fno-common) build
Closes: https://bugs.gentoo.org/708520 Signed-off-by: Alexandra Parker <alex.iris.parker@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-plugins/gimp-lqr')
-rw-r--r--media-plugins/gimp-lqr/files/gimp-lqr-0.7.2-gcc-10-fno-common.patch52
-rw-r--r--media-plugins/gimp-lqr/gimp-lqr-0.7.2.ebuild4
2 files changed, 56 insertions, 0 deletions
diff --git a/media-plugins/gimp-lqr/files/gimp-lqr-0.7.2-gcc-10-fno-common.patch b/media-plugins/gimp-lqr/files/gimp-lqr-0.7.2-gcc-10-fno-common.patch
new file mode 100644
index 000000000000..2f253cb0ac52
--- /dev/null
+++ b/media-plugins/gimp-lqr/files/gimp-lqr-0.7.2-gcc-10-fno-common.patch
@@ -0,0 +1,52 @@
+https://bugs.gentoo.org/708520
+https://github.com/carlobaldassi/gimp-lqr-plugin/issues/7
+--- a/src/interface_aux.c 2013-08-05 06:06:03.000000000 -0700
++++ b/src/interface_aux.c 2020-10-06 10:44:45.349564022 -0700
+@@ -48,11 +48,11 @@
+
+ gint dialog_aux_response = GTK_RESPONSE_OK;
+
+-PlugInUIVals *ui_state;
+-PlugInVals *state;
+-PlugInDialogVals *dialog_state;
++extern PlugInUIVals *ui_state;
++extern PlugInVals *state;
++extern PlugInDialogVals *dialog_state;
+
+-GtkWidget *dlg;
++extern GtkWidget *dlg;
+
+ /*** Public functions ***/
+
+--- a/src/interface_I.c 2013-08-05 06:06:03.000000000 -0700
++++ b/src/interface_I.c 2020-10-06 10:44:45.349564022 -0700
+@@ -65,13 +65,13 @@
+
+ gint dialog_I_response = GTK_RESPONSE_OK;
+
+-PlugInUIVals *ui_state;
+-PlugInVals *state;
+-PlugInDialogVals *dialog_state;
+-gboolean features_are_sensitive;
++extern PlugInUIVals *ui_state;
++extern PlugInVals *state;
++extern PlugInDialogVals *dialog_state;
++extern gboolean features_are_sensitive;
+ InterfaceIData interface_I_data;
+
+-GtkWidget *dlg;
++extern GtkWidget *dlg;
+ GtkWidget *coordinates;
+
+ gulong size_changed = 0;
+--- a/src/main.c 2013-08-05 06:06:03.000000000 -0700
++++ a/src/main.c 2020-10-06 10:44:45.349564022 -0700
+@@ -179,7 +179,7 @@
+ {GIMP_PDB_INT32, "resize_aux_layers",
+ "Whether to resize auxiliary layers"},
+ {GIMP_PDB_INT32, "resize_canvas", "Whether to resize canvas"},
+- {GIMP_PDB_INT32, "output target", "Output target (same layer, new layer, new image)"},
++ {GIMP_PDB_INT32, "output_target", "Output target (same layer, new layer, new image)"},
+ {GIMP_PDB_INT32, "seams", "Whether to output the seam map"},
+ {GIMP_PDB_INT32, "nrg_func", "Energy function to use"},
+ {GIMP_PDB_INT32, "res_order", "Resize order"},
diff --git a/media-plugins/gimp-lqr/gimp-lqr-0.7.2.ebuild b/media-plugins/gimp-lqr/gimp-lqr-0.7.2.ebuild
index 83a4ea2f875a..d040db2f7e36 100644
--- a/media-plugins/gimp-lqr/gimp-lqr-0.7.2.ebuild
+++ b/media-plugins/gimp-lqr/gimp-lqr-0.7.2.ebuild
@@ -18,3 +18,7 @@ RDEPEND="
>=media-gfx/gimp-2.8
media-libs/liblqr"
DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7.2-gcc-10-fno-common.patch"
+)