summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-22 12:52:13 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-22 12:52:13 +0100
commit90f36c66719e6ae5fcc10bc9ac8911f6b2de700e (patch)
tree99bdb95ef93995bcf2385e70a26264168df3bc22 /media-plugins/gmpc-libnotify
parentmedia-plugins/gmpc-mmkeys: Port to EAPI 7 (diff)
downloadgentoo-90f36c66719e6ae5fcc10bc9ac8911f6b2de700e.tar.gz
gentoo-90f36c66719e6ae5fcc10bc9ac8911f6b2de700e.tar.bz2
gentoo-90f36c66719e6ae5fcc10bc9ac8911f6b2de700e.zip
media-plugins/gmpc-libnotify: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-plugins/gmpc-libnotify')
-rw-r--r--media-plugins/gmpc-libnotify/gmpc-libnotify-11.8.16.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/media-plugins/gmpc-libnotify/gmpc-libnotify-11.8.16.ebuild b/media-plugins/gmpc-libnotify/gmpc-libnotify-11.8.16.ebuild
index 93b469028709..7bca10979738 100644
--- a/media-plugins/gmpc-libnotify/gmpc-libnotify-11.8.16.ebuild
+++ b/media-plugins/gmpc-libnotify/gmpc-libnotify-11.8.16.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="This plugin sends an announcement to the notification daemon on song change"
HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_LIBNOTIFY"
@@ -12,13 +12,17 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="nls"
-RDEPEND=">=media-sound/gmpc-${PV}
- dev-libs/libxml2
+RDEPEND="
+ >=media-sound/gmpc-${PV}
+ dev-libs/libxml2:2
x11-libs/libnotify"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
- nls? ( dev-util/intltool
- sys-devel/gettext )"
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
src_configure() {
econf $(use_enable nls)
@@ -26,5 +30,7 @@ src_configure() {
src_install() {
default
- find "${ED}" -name "*.la" -exec rm {} + || die
+
+ # plugins only
+ find "${D}" -name '*.la' -delete || die
}