summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/grilo-plugins/grilo-plugins-0.2.12.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/grilo-plugins/grilo-plugins-0.2.12.ebuild')
-rw-r--r--media-plugins/grilo-plugins/grilo-plugins-0.2.12.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/media-plugins/grilo-plugins/grilo-plugins-0.2.12.ebuild b/media-plugins/grilo-plugins/grilo-plugins-0.2.12.ebuild
new file mode 100644
index 000000000000..073b50faa3a4
--- /dev/null
+++ b/media-plugins/grilo-plugins/grilo-plugins-0.2.12.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A framework for easy media discovery and browsing"
+HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.2"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="daap +dvd flickr freebox gnome-online-accounts lua pocket tracker upnp-av +vimeo +youtube"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=media-libs/grilo-0.2.10:${SLOT}[network,playlist]
+ >=media-libs/libmediaart-0.1:1.0
+
+ dev-libs/gmime:2.6
+ dev-libs/json-glib
+ dev-libs/libxml2:2
+ dev-db/sqlite:3
+
+ daap? ( >=net-libs/libdmapsharing-2.9.12:3.0 )
+ dvd? ( >=dev-libs/totem-pl-parser-3.4.1 )
+ flickr? ( net-libs/liboauth )
+ freebox? ( net-dns/avahi )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.7.1 )
+ lua? ( >=dev-lang/lua-5.2 )
+ pocket? (
+ dev-libs/json-glib
+ >=net-libs/gnome-online-accounts-3.11.4
+ >=net-libs/rest-0.7
+ >=dev-libs/totem-pl-parser-3.4.1 )
+ tracker? ( >=app-misc/tracker-0.10.5:= )
+ youtube? (
+ >=dev-libs/libgdata-0.9.1
+ dev-libs/totem-pl-parser )
+ upnp-av? (
+ net-libs/gssdp
+ >=net-libs/gupnp-0.13
+ >=net-libs/gupnp-av-0.5 )
+ vimeo? (
+ dev-libs/libgcrypt:0
+ dev-libs/totem-pl-parser )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # --enable-debug only changes CFLAGS, useless for us
+ # Plugins
+ # shoutcast seems to be broken
+ gnome2_src_configure \
+ --disable-static \
+ --disable-debug \
+ --disable-uninstalled \
+ --enable-bliptv \
+ --enable-apple-trailers \
+ --enable-bookmarks \
+ --enable-filesystem \
+ --enable-gravatar \
+ --enable-jamendo \
+ --enable-lastfm-albumart \
+ --enable-localmetadata \
+ --enable-magnatune \
+ --enable-metadata-store \
+ --enable-podcasts \
+ --enable-raitv \
+ --disable-shoutcast \
+ --enable-tmdb \
+ $(use_enable daap dmap) \
+ $(use_enable dvd optical-media) \
+ $(use_enable flickr) \
+ $(use_enable freebox) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable lua lua-factory) \
+ $(use_enable pocket) \
+ $(use_enable tracker) \
+ $(use_enable upnp-av upnp) \
+ $(use_enable vimeo) \
+ $(use_enable youtube)
+}