summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/gst-plugins-faad/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/gst-plugins-faad/files')
-rw-r--r--media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch b/media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch
new file mode 100644
index 000000000000..fdcdc7554482
--- /dev/null
+++ b/media-plugins/gst-plugins-faad/files/gst-plugins-faad-1.4.5-version-check.patch
@@ -0,0 +1,38 @@
+From bde0f119097117cf0256e450af4267a47782260b Mon Sep 17 00:00:00 2001
+From: Wim Taymans <wtaymans@redhat.com>
+Date: Wed, 13 May 2015 16:23:26 +0200
+Subject: [PATCH] fix faad2 version check
+
+On fedora 22, the output of cpp inserts extra debug comments, which
+makes our regexp for the faad2 version check fail. This in turn causes
+it to compile with the wrong arguments passed which then causes stack
+corruption and crashes.
+
+Fix this by only checking for the version (which should be by itself on
+a single line). This is potentially less safe, it might be possible that
+a similar string would appear in a later version in the header file.
+
+Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4e2823e..c56295e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2050,9 +2050,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
+ AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
+ for minor in 10 9 8 7 6 5 0; do
+ if test x$faad2_minor_version = "x"; then
+- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
++ AC_EGREP_CPP([\"2\.$minor\"$], [
+ #include <$faad_hdr>
+- GST_CHECK_FAAD_VERSION FAAD2_VERSION
++ FAAD2_VERSION
+ ], [
+ faad2_minor_version=$minor
+ ])
+--
+2.4.1
+