summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-02-25 21:28:55 +0200
committerMart Raudsepp <leio@gentoo.org>2017-02-25 22:43:37 +0200
commit589fdf51ca392905fa061248e8291ee69de16f7c (patch)
treed553a8cf1f4eaf15f1d54e178ccd3ae9a418af21 /media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.4.ebuild
parentmedia-plugins/gst-plugins-faad: bump to 1.10.4, no code changes compared to 1... (diff)
downloadgentoo-589fdf51ca392905fa061248e8291ee69de16f7c.tar.gz
gentoo-589fdf51ca392905fa061248e8291ee69de16f7c.tar.bz2
gentoo-589fdf51ca392905fa061248e8291ee69de16f7c.zip
media-plugins/gst-plugins-hls: bump to 1.10.4 for upstream bug fixes
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.4.ebuild')
-rw-r--r--media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.4.ebuild b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.4.ebuild
new file mode 100644
index 000000000000..9364ac942873
--- /dev/null
+++ b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="HTTP live streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/nettle:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # FIXME: gsturidownloader does not have a .pc
+ # gstreamer_system_link \
+ # gst-libs/gst/uridownloader:gsturidownloader \
+ # gst-libs/gst/adaptativedemux:gstadaptivedemux
+
+ local directory libs
+ directory="gst-libs/gst/uridownloader"
+ libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgsturidownloader-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/hls/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/adaptivedemux"
+ libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgstapp-1.0 -lgsturidownloader-1.0 -lgstadaptivedemux-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/hls/Makefile.{am,in} || die
+}
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure \
+ --with-hls-crypto=nettle
+}