summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/gst-plugins-smoothstreaming
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/gst-plugins-smoothstreaming')
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/Manifest2
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.2.4-r1.ebuild27
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.4.5.ebuild27
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/metadata.xml5
4 files changed, 61 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/Manifest b/media-plugins/gst-plugins-smoothstreaming/Manifest
new file mode 100644
index 000000000000..a9a03522c82f
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/Manifest
@@ -0,0 +1,2 @@
+DIST gst-plugins-bad-1.2.4.tar.xz 3272824 SHA256 984c133ec9d5d705e313d9e2bbd1472b93c6567460602a9a316578925ffe2eca SHA512 4344dedb899cdc0e3bf36a3b5dd36c6091e2e2f2a7440e3831cebbd9b4463f89cc4bc2d589b0c2c806bcaeb1864a49b3c9e0e3bedc051f1f46e09a8f131f0aa9 WHIRLPOOL 98bce50e7018d7c8d442bf8c7f26f14bd719a8af5af0fde39841c4282a9e4edfeefe06ab10797826cf9b876e173dafcf2e2df86408c373e6c4d8902072cf393c
+DIST gst-plugins-bad-1.4.5.tar.xz 3824936 SHA256 152fad7250683d72f9deb36c5685428338365fe4a4c87ffe15e38783b14f983c SHA512 65d6be58957b1329420611b8e6f1eb9869420745d9165047631cdf9e45083605f37dcfaf68a288fe4252f1b3543f7f70ded9c12eab2e0ac4ac9f4c4ce9eaac7a WHIRLPOOL f5ade3f101ca82b52e7145e5ac16f5c1ab5d042415ee7753586dc6ad0942467c4c5b5b4aa6b0bc44e1ebd9c40de1964df265aa41599cb692fd32aab2b6a7acf7
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.2.4-r1.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..2320bdbdeb63
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.2.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GST_ORG_MODULE=gst-plugins-bad
+inherit gstreamer
+
+DESCRIPTION="Smooth Streaming plugin"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# FIXME: gsturidownloader does not have a .pc
+src_prepare() {
+ gstreamer_system_link \
+ gst-libs/gst/codecparsers:gstreamer-codecparsers
+ #gst-libs/gst/uridownloader:gsturidownloader
+}
+
+multilib_src_compile() {
+ emake -C gst-libs/gst/uridownloader
+ gstreamer_multilib_src_compile
+}
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.4.5.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.4.5.ebuild
new file mode 100644
index 000000000000..3655a763df0b
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.4.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="Smooth Streaming plugin"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# FIXME: gsturidownloader does not have a .pc
+src_prepare() {
+ gstreamer_system_link \
+ gst-libs/gst/codecparsers:gstreamer-codecparsers
+ #gst-libs/gst/uridownloader:gsturidownloader
+}
+
+multilib_src_compile() {
+ emake -C gst-libs/gst/uridownloader
+ gstreamer_multilib_src_compile
+}
diff --git a/media-plugins/gst-plugins-smoothstreaming/metadata.xml b/media-plugins/gst-plugins-smoothstreaming/metadata.xml
new file mode 100644
index 000000000000..9e260ceca3e3
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gstreamer</herd>
+</pkgmetadata>