summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-02-10 21:48:58 +0200
committerMart Raudsepp <leio@gentoo.org>2017-02-11 16:52:14 +0200
commit6702286819d39a0d48cd40bd13a88138ff95c660 (patch)
treebcd3df8b2ba910aad0f2227ff75e3d1c143f05b4 /media-plugins/gst-plugins-smoothstreaming
parentmedia-plugins/gst-plugins-schroedinger: bump to 1.10.3 (diff)
downloadgentoo-6702286819d39a0d48cd40bd13a88138ff95c660.tar.gz
gentoo-6702286819d39a0d48cd40bd13a88138ff95c660.tar.bz2
gentoo-6702286819d39a0d48cd40bd13a88138ff95c660.zip
media-plugins/gst-plugins-smoothstreaming: bump to 1.10.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-plugins/gst-plugins-smoothstreaming')
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/Manifest1
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.10.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/Manifest b/media-plugins/gst-plugins-smoothstreaming/Manifest
index 35e0b5845d17..dacb7d9b2ee7 100644
--- a/media-plugins/gst-plugins-smoothstreaming/Manifest
+++ b/media-plugins/gst-plugins-smoothstreaming/Manifest
@@ -1 +1,2 @@
+DIST gst-plugins-bad-1.10.3.tar.xz 4734656 SHA256 24099351fb6984c9e7560de06e072ff2e33d0b2db38b8fcc7afefb536e5094e7 SHA512 028e2c579d6e41fed2a3b7de91f3e0eac08fecd52bd67f198437909025aa41dbf4fd7ddd76decd989f8c4ca7664fad3517b403b326d8ef297bfdd006b5d79944 WHIRLPOOL 744f76c10fc534156abb49d71b4f01c663d8c14b3eb4ced988a41b0b3e1e455b988a2b2064af96f5e75f65622f6e5077c08016e29d68b12864f33fea664a613c
DIST gst-plugins-bad-1.8.3.tar.xz 4500300 SHA256 7899fcb18e6a1af2888b19c90213af018a57d741c6e72ec56b133bc73ec8509b SHA512 3676903fea7a5b078187c3b295208bc24b567ba4e965035db603cf8106e34ca619668253ff4320b192c4e3d1698572e6591bf7fb7253bd2399e7986711bb85c4 WHIRLPOOL 7dbe853dd83b15c33a78da1cbe43d121dd92e90b9b0016ba8f77fbc8f4b6c4167fd508ed9ae0370c03a2b548a765539ed7a45e5dd0418bb6f66d789e133ee7c5
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.10.3.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.10.3.ebuild
new file mode 100644
index 000000000000..27cadc9c1c90
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.10.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="Smooth Streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # FIXME: gsturidownloader does not have a .pc
+ # gst-libs/gst/uridownloader:gsturidownloader \
+ # gst-libs/gst/adaptativedemux:gstadaptivedemux
+ gstreamer_system_link \
+ gst-libs/gst/codecparsers:gstreamer-codecparsers
+
+ local directory libs
+ directory="gst-libs/gst/uridownloader"
+ libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgsturidownloader-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/adaptivedemux"
+ libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgstapp-1.0 -lgsturidownloader-1.0 -lgstadaptivedemux-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+}