summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2020-08-03 13:52:17 +0300
committerCraig Andrews <candrews@gentoo.org>2020-08-13 16:50:41 -0400
commitcccda3c0822835111a8de07c930d9fc1f5a2881e (patch)
tree85fabd209651b188ad187cca2927469759253f06 /media-plugins/kodi-inputstream-adaptive
parentmedia-plugins/kodi-visualization-waveform: fixed build, licence (diff)
downloadgentoo-cccda3c0822835111a8de07c930d9fc1f5a2881e.tar.gz
gentoo-cccda3c0822835111a8de07c930d9fc1f5a2881e.tar.bz2
gentoo-cccda3c0822835111a8de07c930d9fc1f5a2881e.zip
media-plugins/kodi-inputstream-adaptive: fixed deps, licence; tweaks
Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Closes: https://github.com/gentoo/gentoo/pull/16971 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-inputstream-adaptive')
-rw-r--r--media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-2.4.5-r1.ebuild43
-rw-r--r--media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-9999.ebuild27
2 files changed, 57 insertions, 13 deletions
diff --git a/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-2.4.5-r1.ebuild b/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-2.4.5-r1.ebuild
new file mode 100644
index 000000000000..1185349b60ef
--- /dev/null
+++ b/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-2.4.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kodi-addon
+
+DESCRIPTION="Kodi's Adaptive inputstream addon"
+HOMEPAGE="https://github.com/peak3d/inputstream.adaptive.git"
+KODI_PLUGIN_NAME="inputstream.adaptive"
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/peak3d/${KODI_PLUGIN_NAME}.git"
+ EGIT_BRANCH="Matrix"
+ inherit git-r3
+ DEPEND="~media-tv/kodi-9999"
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/peak3d/${KODI_PLUGIN_NAME}/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${KODI_PLUGIN_NAME}-${PV}-${CODENAME}"
+ DEPEND="=media-tv/kodi-18*:="
+ ;;
+esac
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+DEPEND+="
+ dev-libs/expat
+ "
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if [ -d depends ]; then rm -rf depends || die; fi
+
+ cmake_src_prepare
+}
diff --git a/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-9999.ebuild b/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-9999.ebuild
index 5b4d4f3e9ca0..18e80d341a6d 100644
--- a/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-9999.ebuild
+++ b/media-plugins/kodi-inputstream-adaptive/kodi-inputstream-adaptive-9999.ebuild
@@ -3,40 +3,41 @@
EAPI=7
-inherit cmake kodi-addon
+inherit kodi-addon
DESCRIPTION="Kodi's Adaptive inputstream addon"
HOMEPAGE="https://github.com/peak3d/inputstream.adaptive.git"
-SRC_URI=""
+KODI_PLUGIN_NAME="inputstream.adaptive"
case ${PV} in
9999)
SRC_URI=""
- EGIT_REPO_URI="https://github.com/peak3d/inputstream.adaptive.git"
+ EGIT_REPO_URI="https://github.com/peak3d/${KODI_PLUGIN_NAME}.git"
EGIT_BRANCH="Matrix"
inherit git-r3
+ DEPEND="~media-tv/kodi-9999"
;;
*)
- KEYWORDS="~amd64 ~x86"
CODENAME="Matrix"
- SRC_URI="https://github.com/peak3d/inputstream.adaptive/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/inputstream.adaptive-${PV}-${CODENAME}"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/peak3d/${KODI_PLUGIN_NAME}/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${KODI_PLUGIN_NAME}-${PV}-${CODENAME}"
+ DEPEND="=media-tv/kodi-19*:="
;;
esac
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
IUSE=""
-DEPEND="
+DEPEND+="
dev-libs/expat
- ~media-tv/kodi-9999
- "
-RDEPEND="
- ${DEPEND}
"
+RDEPEND="${DEPEND}"
+
src_prepare() {
- [ -d depends ] && rm -rf depends || die
+ if [ -d depends ]; then rm -rf depends || die; fi
+
cmake_src_prepare
}