summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-03-01 21:00:13 -0500
committerCraig Andrews <candrews@gentoo.org>2019-03-01 21:00:26 -0500
commit698d7756127ee9cddacd8e9420b332db01281e5d (patch)
tree4f9172dff9eaebe6d575b8b4f133072262f6532c /media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.16.ebuild
parentdev-haskell/parallel-io: new revision to fix "containers" bound. (diff)
downloadgentoo-698d7756127ee9cddacd8e9420b332db01281e5d.tar.gz
gentoo-698d7756127ee9cddacd8e9420b332db01281e5d.tar.bz2
gentoo-698d7756127ee9cddacd8e9420b332db01281e5d.zip
media-plugins/kodi-pvr-hts: 4.4.16 version bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.16.ebuild')
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.16.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.16.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.16.ebuild
new file mode 100644
index 000000000000..5b0620a24709
--- /dev/null
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Tvheadend Live TV and Radio PVR client addon for Kodi"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
+SRC_URI=""
+
+if [[ ${PV} == 9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
+ inherit git-r3
+else
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.hts-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =dev-libs/libplatform-2*
+ =media-libs/kodi-platform-18*
+ =media-tv/kodi-18*
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "