summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-05-16 18:18:45 -0400
committerCraig Andrews <candrews@gentoo.org>2019-05-16 18:19:04 -0400
commit3a1522477460fde195940a8420e686c38f3a5210 (patch)
treec01361ba2504f730e52d6fe0a7ee68aeeda5bc1c /media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.18.ebuild
parentapp-text/qpdf: arm64 stable (diff)
downloadgentoo-3a1522477460fde195940a8420e686c38f3a5210.tar.gz
gentoo-3a1522477460fde195940a8420e686c38f3a5210.tar.bz2
gentoo-3a1522477460fde195940a8420e686c38f3a5210.zip
media-plugins/kodi-pvr-hts: 4.4.18 version bump
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.18.ebuild')
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.18.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.18.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.18.ebuild
new file mode 100644
index 000000000000..5b0620a24709
--- /dev/null
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-4.4.18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Tvheadend Live TV and Radio PVR client addon for Kodi"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
+SRC_URI=""
+
+if [[ ${PV} == 9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
+ inherit git-r3
+else
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.hts-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =dev-libs/libplatform-2*
+ =media-libs/kodi-platform-18*
+ =media-tv/kodi-18*
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "