summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-10-17 22:15:31 -0400
committerCraig Andrews <candrews@gentoo.org>2020-10-17 22:17:37 -0400
commit7687db19c0a55bfbce58551c58fce5d3184c285f (patch)
tree5ba222455043240eb61a745be7ab79e4968b196c /media-plugins/kodi-pvr-hts
parentprofiles/arch/powerpc/ppc64/64le/package.mask: unmask docker (diff)
downloadgentoo-7687db19c0a55bfbce58551c58fce5d3184c285f.tar.gz
gentoo-7687db19c0a55bfbce58551c58fce5d3184c285f.tar.bz2
gentoo-7687db19c0a55bfbce58551c58fce5d3184c285f.zip
media-plugins/kodi-pvr-hts: 7.2.0 version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-pvr-hts')
-rw-r--r--media-plugins/kodi-pvr-hts/Manifest1
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.2.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-plugins/kodi-pvr-hts/Manifest b/media-plugins/kodi-pvr-hts/Manifest
index 7898556ae860..ab5b2938207e 100644
--- a/media-plugins/kodi-pvr-hts/Manifest
+++ b/media-plugins/kodi-pvr-hts/Manifest
@@ -7,3 +7,4 @@ DIST kodi-pvr-hts-4.4.18.tar.gz 161525 BLAKE2B 22d869989fc2151ca5ec39c7802d4612d
DIST kodi-pvr-hts-4.4.20.tar.gz 161693 BLAKE2B d69e72c8d189b540f2d8abc97c50e5a9e93346823333fe2441d3f7b625b94de72dfe50f6e8af5d17506265746819fff1a3d1f1e06ba7b79934ce234151940525 SHA512 aa8ed5487fa00c7cdc13aa167f103daa2a2cbfd93da2414fa85a339edbca3dda056e1073d52bd3a752e00652e83e3c5ddd1de42741600b9da143b18557f598be
DIST kodi-pvr-hts-7.1.1.tar.gz 167379 BLAKE2B f2391d7997a7e17ed1fb7b2326cdb0cddfecdf9a6b0785fc89ecf8b58004575c6b7a1f6efb976edda827b9e83d334e0bba518498886c1e1769b9ed1deacf25d7 SHA512 5d1e049c23e82964ab87b22c716028d57322f81b749f84f07f66e3bbd2990e711186eee2b562d1f326a369b5fc52d1f7b2aea31b4d8edc827f6555965fec2b69
DIST kodi-pvr-hts-7.1.4.tar.gz 167634 BLAKE2B 34c19b9be6f8e66c22b93e74703d55ccf66970fb39b4c2ac52146aa9d94175280406339fbe6651a53be4b9216713dbeb25fc004f9959a1ce1db42e13b0aec2f7 SHA512 91f9420ad88ec806d2d16e618827583039b90e488014d0f998108c9d94906aa247755f5d53dc4b59badc9fdfad96c975b0d7c98ef0ffd7116171e8abd247c94b
+DIST kodi-pvr-hts-7.2.0.tar.gz 167998 BLAKE2B 4da53589b58849259d66a03d2f719067cc1749ea181ad6037f03ca178879a34e209422039a1b2d0b3900ee2a2ef65d32a09cae0f177dc17dd8aa97e06dea4f2b SHA512 736188c4464c9110e4916223cd0aa79195547d4ff568aea711aa42c1145d5aa981d1d5f62d4ed79b37575592bda9f2bbc532eff7b09e48785e644e8fdea668c0
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.2.0.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.2.0.ebuild
new file mode 100644
index 000000000000..764206faf8d3
--- /dev/null
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Tvheadend Live TV and Radio PVR client addon for Kodi"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
+SRC_URI=""
+
+if [[ ${PV} == 9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
+ inherit git-r3
+else
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.hts-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =dev-libs/libplatform-2*
+ =media-tv/kodi-19*
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "