summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-09-05 12:53:48 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-09-05 12:54:52 +0200
commit0b752c3ee0714ca50daa0ea3816f03c1b792863c (patch)
treed641c869c97eb3db79af0a9ba465631d8e0e41d1 /media-plugins/libvisual-plugins
parentapp-portage/gemato: Require pytest>=5 (diff)
downloadgentoo-0b752c3ee0714ca50daa0ea3816f03c1b792863c.tar.gz
gentoo-0b752c3ee0714ca50daa0ea3816f03c1b792863c.tar.bz2
gentoo-0b752c3ee0714ca50daa0ea3816f03c1b792863c.zip
media-plugins/libvisual-plugins: fixed clang compilation in 0.4.0-r4
Closes: https://bugs.gentoo.org/740304 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-plugins/libvisual-plugins')
-rw-r--r--media-plugins/libvisual-plugins/files/libvisual-plugins-0.4.0-clang.patch42
-rw-r--r--media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild1
2 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/libvisual-plugins/files/libvisual-plugins-0.4.0-clang.patch b/media-plugins/libvisual-plugins/files/libvisual-plugins-0.4.0-clang.patch
new file mode 100644
index 000000000000..25c2880fa0c5
--- /dev/null
+++ b/media-plugins/libvisual-plugins/files/libvisual-plugins-0.4.0-clang.patch
@@ -0,0 +1,42 @@
+diff --git a/plugins/actor/G-Force/Common/UI/LineXX.cpp b/plugins/actor/G-Force/Common/UI/LineXX.cpp
+index 304eec8..5b18503 100644
+--- a/plugins/actor/G-Force/Common/UI/LineXX.cpp
++++ b/plugins/actor/G-Force/Common/UI/LineXX.cpp
+@@ -74,13 +74,13 @@
+
+
+ #if CLR_INTERP && P_SZ != 1
+- int32_t len = sqrt( dx * dx + dy * dy ) + 1;
++ int32_t len = sqrt( (long double) dx * dx + dy * dy ) + 1;
+ dR /= len;
+ dG /= len;
+ dB /= len;
+ color = __Clr( R, G, B );
+ #elif CLR_INTERP && P_SZ == 1
+- int32_t len = sqrt( dx * dx + dy * dy ) + 1;
++ int32_t len = sqrt( (long double) dx * dx + dy * dy ) + 1;
+ dR /= len;
+ color = __Clr( R, G, B );
+ #endif
+@@ -154,7 +154,7 @@
+
+ for ( j = 0; j < tw; j++ ) {
+ int32_t tmp = j - halfW;
+- c_x = halfW - ( ( int32_t ) sqrt( halfW * halfW - tmp * tmp ) );
++ c_x = halfW - ( ( int32_t ) sqrt( (long double) halfW * halfW - tmp * tmp ) );
+ center = basePtr + (j-halfW) * mBytesPerRow;
+ for ( int k = c_x; k < tw - c_x; k++ ){
+ ((PIXTYPE*) center)[k-halfW] = color;
+diff --git a/plugins/morph/flash/morph_flash.c b/plugins/morph/flash/morph_flash.c
+index fb5308a..c57f490 100644
+--- a/plugins/morph/flash/morph_flash.c
++++ b/plugins/morph/flash/morph_flash.c
+@@ -116,7 +116,7 @@ int lv_morph_flash_palette (VisPluginData *plugin, float rate, VisAudio *audio,
+ FlashPrivate *priv = visual_object_get_private (VISUAL_OBJECT (plugin));
+
+ if (src1->pal == NULL || src2->pal == NULL)
+- return;
++ return -1;
+
+ if (rate < 0.5)
+ visual_palette_blend (pal, src1->pal, &priv->whitepal, rate * 2);
diff --git a/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild b/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild
index 401d8343726d..01b17e2e5ae4 100644
--- a/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild
+++ b/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild
@@ -38,6 +38,7 @@ DOCS=( AUTHORS ChangeLog NEWS README TODO )
PATCHES=(
"${FILESDIR}/${P}-fno-common.patch"
+ "${FILESDIR}/${P}-clang.patch"
)
src_prepare() {