summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-01 11:08:59 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-01 11:26:53 +0200
commitb471613efdd29f68f4304fd6232179a380ca701f (patch)
treeb2321bfc34c10b669b1209fa68f8a9eea3f70970 /media-plugins/libvisual-plugins
parentsys-devel/bison: stable 3.6.4 for sparc (diff)
downloadgentoo-b471613efdd29f68f4304fd6232179a380ca701f.tar.gz
gentoo-b471613efdd29f68f4304fd6232179a380ca701f.tar.bz2
gentoo-b471613efdd29f68f4304fd6232179a380ca701f.zip
media-plugins/libvisual-plugins: fixed building with gcc10 and homepage
Bug: https://bugs.gentoo.org/616372 Closes: https://bugs.gentoo.org/708634 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-plugins/libvisual-plugins')
-rw-r--r--media-plugins/libvisual-plugins/files/libvisual-plugins-0.4.0-fno-common.patch17
-rw-r--r--media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild3
-rw-r--r--media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild8
3 files changed, 25 insertions, 3 deletions
diff --git a/media-plugins/libvisual-plugins/files/libvisual-plugins-0.4.0-fno-common.patch b/media-plugins/libvisual-plugins/files/libvisual-plugins-0.4.0-fno-common.patch
new file mode 100644
index 000000000000..5544d1895e02
--- /dev/null
+++ b/media-plugins/libvisual-plugins/files/libvisual-plugins-0.4.0-fno-common.patch
@@ -0,0 +1,17 @@
+--- a/plugins/actor/oinksie/table.h
++++ b/plugins/actor/oinksie/table.h
+@@ -27,10 +27,10 @@
+ #define OINK_TABLE_NORMAL_SIZE 1200
+ #define OINK_TABLE_LARGE_SIZE 12000
+
+-float _oink_table_sin[OINK_TABLE_NORMAL_SIZE];
+-float _oink_table_cos[OINK_TABLE_NORMAL_SIZE];
+-float _oink_table_sinlarge[OINK_TABLE_LARGE_SIZE];
+-float _oink_table_coslarge[OINK_TABLE_LARGE_SIZE];
++extern float _oink_table_sin[OINK_TABLE_NORMAL_SIZE];
++extern float _oink_table_cos[OINK_TABLE_NORMAL_SIZE];
++extern float _oink_table_sinlarge[OINK_TABLE_LARGE_SIZE];
++extern float _oink_table_coslarge[OINK_TABLE_LARGE_SIZE];
+
+ void _oink_table_init ();
+
diff --git a/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild b/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild
index 2ebdcaae9d40..b15a83b81fde 100644
--- a/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild
+++ b/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild
@@ -7,7 +7,7 @@ inherit autotools eutils ltprune multilib-minimal
PATCHLEVEL=4
DESCRIPTION="collection of visualization plugins for use with the libvisual framework"
-HOMEPAGE="http://libvisual.sourceforge.net/"
+HOMEPAGE="http://libvisual.org/"
SRC_URI="mirror://sourceforge/libvisual/${P}.tar.gz
mirror://gentoo/${P}-patches-${PATCHLEVEL}.tar.bz2
mirror://gentoo/${P}-m4-1.tar.bz2"
@@ -37,6 +37,7 @@ DOCS="AUTHORS ChangeLog NEWS README TODO"
src_prepare() {
EPATCH_SUFFIX=patch epatch "${WORKDIR}"/patches
+ epatch "${FILESDIR}/${P}-fno-common.patch"
AT_M4DIR=${WORKDIR}/m4 eautoreconf
sed -i -e "s:@MKINSTALLDIRS@:${S}/mkinstalldirs:" po/Makefile.* || die
diff --git a/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild b/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild
index 2ed770311065..8c664230ca52 100644
--- a/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild
+++ b/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r4.ebuild
@@ -7,7 +7,7 @@ inherit autotools eutils multilib-minimal
PATCHLEVEL=4
DESCRIPTION="collection of visualization plugins for use with the libvisual framework"
-HOMEPAGE="http://libvisual.sourceforge.net/"
+HOMEPAGE="http://libvisual.org/"
SRC_URI="mirror://sourceforge/libvisual/${P}.tar.gz
mirror://gentoo/${P}-patches-${PATCHLEVEL}.tar.bz2
mirror://gentoo/${P}-m4-1.tar.bz2"
@@ -36,6 +36,10 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README TODO"
+PATCHES=(
+ "${FILESDIR}/${P}-fno-common.patch"
+)
+
src_prepare() {
# Can't use eapply on ${WORKDIR}/patches since the patches use different
# values for -p. epatch handled that automatically, eapply doesn't
@@ -49,7 +53,7 @@ src_prepare() {
eapply -p1 "${WORKDIR}"/patches/070_all_gforce-fbsd.patch
eapply -p1 "${WORKDIR}"/patches/080_all_qa.patch
eapply -p1 "${WORKDIR}"/patches/090_all_nastyfft.patch
- eapply_user
+ default
AT_M4DIR=${WORKDIR}/m4 eautoreconf