summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-23 12:50:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-23 12:50:31 +0200
commit05e00697808d53d8d6511bbaef6d6c3d798013f0 (patch)
treebfedf3a194c1e3030806e180f571ddf896df6560 /media-plugins/live
parentmedia-sound/darkice: Bump to version 1.3 (diff)
downloadgentoo-05e00697808d53d8d6511bbaef6d6c3d798013f0.tar.gz
gentoo-05e00697808d53d8d6511bbaef6d6c3d798013f0.tar.bz2
gentoo-05e00697808d53d8d6511bbaef6d6c3d798013f0.zip
media-plugins/live: bump to 2016.09.22
Package-Manager: portage-2.3.1
Diffstat (limited to 'media-plugins/live')
-rw-r--r--media-plugins/live/Manifest1
-rw-r--r--media-plugins/live/live-2016.09.22.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/media-plugins/live/Manifest b/media-plugins/live/Manifest
index 51e3e599a9b6..a11ca2ca7f8f 100644
--- a/media-plugins/live/Manifest
+++ b/media-plugins/live/Manifest
@@ -5,3 +5,4 @@ DIST live.2016.07.19.tar.gz 619591 SHA256 a86abfb8d0bdb04e2d0e1ae07de4eb03b8f4da
DIST live.2016.08.27.tar.gz 619652 SHA256 2fd0bcb4b4f0dc15991550b0080eebc4cf586d8f1678c116f8e7a5ec1edbc034 SHA512 e1a43ebada300bd7ef6a3e29a073a9b87d27d5b1076516c21c5f76db57c6088f8477110316c234201c97214f7a78d27cda3b963db1d7d15e46ec189c918a4a85 WHIRLPOOL dbf30a36a2016c913a6a81555c1d485a5247f1499f24eea681fadfa7bea640d9cee2b962f2c23f2ac0c5f3f12b39ca904547089b8ceb6e127a3efc7c31ccbb40
DIST live.2016.09.05.tar.gz 619725 SHA256 afd7bd5fd928737b4ae73bb2557cd6e84aa1eb1c9c9e7d6e9b103954ee2a8cee SHA512 0098d26195879c6a9915aef99e41049bdc2244d04209477b2943aa031c6e1b64775d27a3bd1d089e6b6d420d51cc076caeeda20b16f14b6e72b730499d38cec9 WHIRLPOOL 8952e8fe418f6efe3732ddd3e9a2df67b5fe580b9d163726d0517b30acead2ab19526b02def6fa55a288c66659229cc7173aabc2301eaff67e6e2bfc083f8bd7
DIST live.2016.09.12.tar.gz 619910 SHA256 09a046d0bf952291d4d70c26de4741ac11f049ee737592e6a251073cb3ecf9e0 SHA512 d45e5a47676e14df17676f25f1ffbd37f43f5f34e5553723e429b28d56a127065620427c1e007cec9a0ef214c6167b039dca89d9c06c291caab36a7e0ba10978 WHIRLPOOL 0114694ce7c2009c69e25dad89084f4619fcd6ed536d0018588b2098e9c80ae1e342c035f2999e01fc2a183e40ce12b1ea22b9f2fc7cbdda8b436479b106db00
+DIST live.2016.09.22.tar.gz 623621 SHA256 4d108205f4f0abe24224c72129222c1a8865e13d67e5dad6f8e900ef346379ff SHA512 ebfb06ea566003b465ce88cbd838c3a00a28c4bb49e27347c95f5dcbee292eea9f742484ea31e3c0ed7aa0fbb704c35e0136335f426e73b29b6cb24658f335a0 WHIRLPOOL 6dbc7643713e6870984176ef51d99908b5b142ad4277b7db89d3d0a9e340d224f267773b711701c2656e8bd32c8bd09b7854e41504b8f6b6f74f9821eb5bd02a
diff --git a/media-plugins/live/live-2016.09.22.ebuild b/media-plugins/live/live-2016.09.22.ebuild
new file mode 100644
index 000000000000..f8ef23f1e3be
--- /dev/null
+++ b/media-plugins/live/live-2016.09.22.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="Libraries for standards-based RTP/RTCP/RTSP multimedia streaming"
+HOMEPAGE="http://www.live555.com/"
+SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz
+ mirror://gentoo/${P/-/.}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples static-libs"
+DOCS=( "live-shared/README" )
+
+# Alexis Ballier <aballier@gentoo.org>
+# Be careful, bump this everytime you bump the package and the ABI has changed.
+# If you don't know, ask someone.
+LIVE_ABI_VERSION=7
+SLOT="0/${LIVE_ABI_VERSION}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${S}"
+ mv "${WORKDIR}/live" "${S}/" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-recursive2.patch"
+
+ if use static-libs ; then
+ cp -pPR live live-shared
+ mv live live-static
+ else
+ mv live live-shared
+ fi
+
+ use static-libs && cp "${FILESDIR}/config.gentoo" live-static
+ cp "${FILESDIR}/config.gentoo-so-r1" live-shared
+
+ case ${CHOST} in
+ *-solaris*)
+ use static-libs && { sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
+ -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
+ live-static/config.gentoo \
+ || die ; }
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
+ -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
+ live-shared/config.gentoo-so-r1 \
+ || die
+ ;;
+ *-darwin*)
+ use static-libs && { sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
+ -e '/^LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
+ live-static/config.gentoo \
+ || die static ; }
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
+ -e '/^LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
+ -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
+ -e '/^LIB_SUFFIX /s/so/dylib/' \
+ live-shared/config.gentoo-so-r1 \
+ || die shared
+ ;;
+ esac
+ multilib_copy_sources
+}
+
+src_configure() { :; }
+
+multilib_src_compile() {
+ tc-export CC CXX LD
+
+ if use static-libs ; then
+ cd "${BUILD_DIR}/live-static"
+
+ einfo "Beginning static library build"
+ ./genMakefiles gentoo
+ emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
+ fi
+
+ cd "${BUILD_DIR}/live-shared"
+ einfo "Beginning shared library build"
+ ./genMakefiles gentoo-so-r1
+ local suffix=$(get_libname ${LIVE_ABI_VERSION})
+ emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"
+
+ for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
+ pushd "${BUILD_DIR}/live-shared/${i}" > /dev/null
+ ln -s lib${i}.${suffix#.} lib${i}$(get_libname) || die
+ popd > /dev/null
+ done
+
+ if multilib_is_native_abi; then
+ einfo "Beginning programs build"
+ for i in $(use examples && echo "testProgs") proxyServer mediaServer ; do
+ cd "${BUILD_DIR}/live-shared/${i}"
+ emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
+ done
+ fi
+}
+
+multilib_src_install() {
+ for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
+ use static-libs && dolib.a live-static/${library}/lib${library}.a
+ dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
+ dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)
+
+ insinto /usr/include/${library}
+ doins live-shared/${library}/include/*h
+ done
+
+ if multilib_is_native_abi; then
+ # Should we really install these?
+ use examples && find live-shared/testProgs -type f -perm 755 -print0 | \
+ xargs -0 dobin
+
+ dobin live-shared/mediaServer/live555MediaServer
+ dobin live-shared/proxyServer/live555ProxyServer
+ fi
+}