summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/npapi-vlc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/npapi-vlc')
-rw-r--r--media-plugins/npapi-vlc/Manifest1
-rw-r--r--media-plugins/npapi-vlc/files/xembed.h38
-rw-r--r--media-plugins/npapi-vlc/metadata.xml8
-rw-r--r--media-plugins/npapi-vlc/npapi-vlc-2.0.0.ebuild58
-rw-r--r--media-plugins/npapi-vlc/npapi-vlc-9999.ebuild57
5 files changed, 162 insertions, 0 deletions
diff --git a/media-plugins/npapi-vlc/Manifest b/media-plugins/npapi-vlc/Manifest
new file mode 100644
index 000000000000..7207271c347d
--- /dev/null
+++ b/media-plugins/npapi-vlc/Manifest
@@ -0,0 +1 @@
+DIST npapi-vlc-2.0.0.tar.xz 359508 RMD160 9653fdde5fe50792f52969e106d6ce7dc279463d SHA1 a7a19f91134fd17c45080743b90251f38026252a SHA256 d41f69b995daf30fb81b2106ca7ad58fde6f4b1c94a2f7b266636c2d949ca6ae
diff --git a/media-plugins/npapi-vlc/files/xembed.h b/media-plugins/npapi-vlc/files/xembed.h
new file mode 100644
index 000000000000..28a1a36d7df1
--- /dev/null
+++ b/media-plugins/npapi-vlc/files/xembed.h
@@ -0,0 +1,38 @@
+#ifndef __XEMBED_H__
+#define __XEMBED_H__
+
+/* the latest version of XEmbed that we support */
+#define PLUGIN_XEMBED_PROTOCOL_VERSION 1
+
+/* XEMBED messages */
+typedef enum {
+ XEMBED_EMBEDDED_NOTIFY = 0,
+ XEMBED_WINDOW_ACTIVATE = 1,
+ XEMBED_WINDOW_DEACTIVATE = 2,
+ XEMBED_REQUEST_FOCUS = 3,
+ XEMBED_FOCUS_IN = 4,
+ XEMBED_FOCUS_OUT = 5,
+ XEMBED_FOCUS_NEXT = 6,
+ XEMBED_FOCUS_PREV = 7,
+ XEMBED_GRAB_KEY = 8,
+ XEMBED_UNGRAB_KEY = 9,
+ XEMBED_MODALITY_ON = 10,
+ XEMBED_MODALITY_OFF = 11,
+
+/* Non standard messages*/
+ XEMBED_GTK_GRAB_KEY = 108,
+ XEMBED_GTK_UNGRAB_KEY = 109
+} XEmbedMessageType;
+
+/* Details for XEMBED_FOCUS_IN: */
+#define XEMBED_FOCUS_CURRENT 0
+#define XEMBED_FOCUS_FIRST 1
+#define XEMBED_FOCUS_LAST 2
+
+/* Flags for XEMBED_FOCUS_IN, XEMBED_FOCUS_NEXT, XEMBED_FOCUS_PREV */
+#define XEMBED_FOCUS_WRAPAROUND (1 << 0)
+
+/* Flags for _XEMBED_INFO */
+#define XEMBED_MAPPED (1 << 0)
+
+#endif /* __XEMBED_H__ */
diff --git a/media-plugins/npapi-vlc/metadata.xml b/media-plugins/npapi-vlc/metadata.xml
new file mode 100644
index 000000000000..0d9b0dcb7f33
--- /dev/null
+++ b/media-plugins/npapi-vlc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-plugins/npapi-vlc/npapi-vlc-2.0.0.ebuild b/media-plugins/npapi-vlc/npapi-vlc-2.0.0.ebuild
new file mode 100644
index 000000000000..33825d40f62e
--- /dev/null
+++ b/media-plugins/npapi-vlc/npapi-vlc-2.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=git-2
+ EGIT_BOOTSTRAP=""
+ EGIT_REPO_URI="git://git.videolan.org/${PN}.git"
+fi
+
+inherit autotools multilib ${SCM}
+
+DESCRIPTION="Mozilla plugin based on VLC"
+HOMEPAGE="http://www.videolan.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="amd64 ~ppc64 x86"
+ SRC_URI="http://download.videolan.org/pub/videolan/vlc/${PV}/${P}.tar.xz"
+ DEPEND="app-arch/xz-utils"
+else
+ KEYWORDS=""
+ SRC_URI=""
+fi
+IUSE="gtk"
+
+RDEPEND=">=media-video/vlc-1.1
+ x11-libs/libX11
+ !gtk? ( x11-libs/libXpm x11-libs/libSM x11-libs/libICE )
+ gtk? ( x11-libs/gtk+:2 )
+ !<media-video/vlc-1.2[nsplugin]"
+DEPEND="${RDEPEND}
+ ${DEPEND}
+ virtual/pkgconfig
+ >=net-misc/npapi-sdk-0.27"
+
+src_prepare() {
+ if [ "${PV%9999}" != "${PV}" ] ; then
+ eautoreconf
+ fi
+ cp "${FILESDIR}/xembed.h" "${S}/npapi/" || die
+}
+
+src_configure() {
+ econf \
+ $(use_with gtk)
+}
+
+src_install() {
+ emake DESTDIR="${D}" npvlcdir="/usr/$(get_libdir)/nsbrowser/plugins" install || die
+ find "${D}" -name '*.la' -delete
+ dodoc NEWS AUTHORS ChangeLog || die
+}
diff --git a/media-plugins/npapi-vlc/npapi-vlc-9999.ebuild b/media-plugins/npapi-vlc/npapi-vlc-9999.ebuild
new file mode 100644
index 000000000000..68c895c33ec7
--- /dev/null
+++ b/media-plugins/npapi-vlc/npapi-vlc-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=git-2
+ EGIT_BOOTSTRAP=""
+ EGIT_REPO_URI="git://git.videolan.org/${PN}.git"
+fi
+
+inherit autotools multilib ${SCM}
+
+DESCRIPTION="Mozilla plugin based on VLC"
+HOMEPAGE="http://www.videolan.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64"
+ SRC_URI="http://download.videolan.org/pub/videolan/vlc/${PV}/${P}.tar.xz"
+ DEPEND="app-arch/xz-utils"
+else
+ KEYWORDS=""
+ SRC_URI=""
+fi
+IUSE="gtk"
+
+RDEPEND=">=media-video/vlc-1.1
+ x11-libs/libX11
+ !gtk? ( x11-libs/libXpm x11-libs/libSM x11-libs/libICE )
+ gtk? ( x11-libs/gtk+:2 )
+ !<media-video/vlc-1.2[nsplugin]"
+DEPEND="${RDEPEND}
+ ${DEPEND}
+ virtual/pkgconfig
+ >=net-misc/npapi-sdk-0.27"
+
+src_prepare() {
+ if [ "${PV%9999}" != "${PV}" ] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with gtk)
+}
+
+src_install() {
+ emake DESTDIR="${D}" npvlcdir="/usr/$(get_libdir)/nsbrowser/plugins" install || die
+ find "${D}" -name '*.la' -delete
+ dodoc NEWS AUTHORS ChangeLog || die
+}