summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vamp-libxtract-plugins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vamp-libxtract-plugins')
-rw-r--r--media-plugins/vamp-libxtract-plugins/Manifest1
-rw-r--r--media-plugins/vamp-libxtract-plugins/metadata.xml5
-rw-r--r--media-plugins/vamp-libxtract-plugins/vamp-libxtract-plugins-0.6.6.20121204.ebuild35
3 files changed, 41 insertions, 0 deletions
diff --git a/media-plugins/vamp-libxtract-plugins/Manifest b/media-plugins/vamp-libxtract-plugins/Manifest
new file mode 100644
index 000000000000..700dce549cb3
--- /dev/null
+++ b/media-plugins/vamp-libxtract-plugins/Manifest
@@ -0,0 +1 @@
+DIST vamp-libxtract-plugins-0.6.6.20121204.tar.gz 20891 SHA256 dfe462a6cba64eacf368cd2f56ad29c747850fbfcde775465aacacebb395495a SHA512 227b848409e4b57be042350ad1dedc8c02c0358239eaf530a0955a4b19ec2c4788e61c7b53b43de5ec1f051a33241e7a4c878584da1480b384756268b501c4c4 WHIRLPOOL 6e603c5e6c47206b370a6a790ae9ef33c9c6c8c9c681c14187cbc30459e328ef1b00047b743c9278c75f9ac411409eab7ba94e456d4eb2ffac3e575ac2dc506e
diff --git a/media-plugins/vamp-libxtract-plugins/metadata.xml b/media-plugins/vamp-libxtract-plugins/metadata.xml
new file mode 100644
index 000000000000..0dc3775f83d7
--- /dev/null
+++ b/media-plugins/vamp-libxtract-plugins/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+</pkgmetadata>
diff --git a/media-plugins/vamp-libxtract-plugins/vamp-libxtract-plugins-0.6.6.20121204.ebuild b/media-plugins/vamp-libxtract-plugins/vamp-libxtract-plugins-0.6.6.20121204.ebuild
new file mode 100644
index 000000000000..063a775f8231
--- /dev/null
+++ b/media-plugins/vamp-libxtract-plugins/vamp-libxtract-plugins-0.6.6.20121204.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Low-level feature extraction plugins using Jamie Bullock's libxtract library to provide around 50 spectral and other features"
+HOMEPAGE="http://www.vamp-plugins.org/"
+SRC_URI="http://code.soundsoftware.ac.uk/attachments/download/618/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="=sci-libs/fftw-3*
+ >=media-libs/libxtract-0.6.6
+ media-libs/vamp-plugin-sdk"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e "s/-O3//" -e "s/ -Wl,-Bstatic//" -i Makefile
+}
+
+src_compile() {
+ tc-export CXX
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/vamp
+ doins vamp-libxtract.{so,cat} || die "doins failed"
+ dodoc README STATUS
+}