summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-actuator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-actuator')
-rw-r--r--media-plugins/vdr-actuator/Manifest1
-rw-r--r--media-plugins/vdr-actuator/metadata.xml12
-rw-r--r--media-plugins/vdr-actuator/vdr-actuator-1.2.1.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/media-plugins/vdr-actuator/Manifest b/media-plugins/vdr-actuator/Manifest
new file mode 100644
index 000000000000..cbf70119d8ee
--- /dev/null
+++ b/media-plugins/vdr-actuator/Manifest
@@ -0,0 +1 @@
+DIST vdr-actuator-1.2.1.tgz 91343 SHA256 22db0563689202c88f6df82ca3a7cc4aed7d542e561b61856d3063834210c7fb SHA512 faed02e0dfd1027e412418023caba7c257d6f7c46ebca89139436bf2769c3b928f103ab2e1d90bd0836db32356e3fa238d5fbef6c5548415cefee0f09c96fd66 WHIRLPOOL 5011dca613afea104f1f760704895773a143dad067d36cb1ea0c2bbc6f7d88672e9d53be95b42b530d62c01c4f8939eab194ae9bbf1f3387a3340ef4461cf137
diff --git a/media-plugins/vdr-actuator/metadata.xml b/media-plugins/vdr-actuator/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-actuator/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-actuator/vdr-actuator-1.2.1.ebuild b/media-plugins/vdr-actuator/vdr-actuator-1.2.1.ebuild
new file mode 100644
index 000000000000..ef880347c638
--- /dev/null
+++ b/media-plugins/vdr-actuator/vdr-actuator-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: control an linear or horizon actuator attached trough the parallel port"
+HOMEPAGE="http://ventoso.org/luca/vdr/"
+SRC_URI="http://ventoso.org/luca/vdr/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.7.23"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ fix_vdr_libsi_include "${S}/scanner.h"
+
+ sed -i -e "s:SystemValues:SystemValuesSat:" actuator.c
+}