summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-admin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-admin')
-rw-r--r--media-plugins/vdr-admin/Manifest1
-rw-r--r--media-plugins/vdr-admin/files/rc-addon.sh31
-rw-r--r--media-plugins/vdr-admin/metadata.xml11
-rw-r--r--media-plugins/vdr-admin/vdr-admin-0.8.0.ebuild51
4 files changed, 94 insertions, 0 deletions
diff --git a/media-plugins/vdr-admin/Manifest b/media-plugins/vdr-admin/Manifest
new file mode 100644
index 000000000000..6d639a94e418
--- /dev/null
+++ b/media-plugins/vdr-admin/Manifest
@@ -0,0 +1 @@
+DIST vdr-admin-0.8.0.tgz 38354 SHA256 e330f91c525f560df109c482d7f49525f99a28a5fe8f17194379a25756a4edb3
diff --git a/media-plugins/vdr-admin/files/rc-addon.sh b/media-plugins/vdr-admin/files/rc-addon.sh
new file mode 100644
index 000000000000..665e1f767599
--- /dev/null
+++ b/media-plugins/vdr-admin/files/rc-addon.sh
@@ -0,0 +1,31 @@
+# $Id$
+#
+# rc-addon-script for plugin admin
+#
+# Joerg Bornkessel <hd_brummy@gentoo.org>
+#
+
+# Location for all plugin config files
+: ${ADMIN_CONF_DIR:=/etc/vdr/plugins/admin}
+
+# Location of the script files
+: ${ADMIN_SCRIPT_PATH:=/etc/vdr/plugins/admin}
+
+# Location of the config file
+: ${ADMIN_CFG_FILE:=${ADMIN_SCRIPT_PATH}/admin.conf}
+
+# Location of the config file
+: ${ADMIN_EXEC_SCRIPT:=${ADMIN_SCRIPT_PATH}/~admexec}
+
+# Location of the log file
+: ${ADMIN_LOG_FILE:=/var/log/vdradmplg.log}
+
+# GETVAl and SETVAL scripts
+: ${GETVAL:=${ADMIN_SCRIPT_PATH}/getadmval.sh}
+: ${SETVAL=${ADMIN_SCRIPT_PATH}/setadmval.sh}
+
+plugin_pre_vdr_start() {
+
+add_plugin_param "-d ${ADMIN_CONF_DIR}"
+
+}
diff --git a/media-plugins/vdr-admin/metadata.xml b/media-plugins/vdr-admin/metadata.xml
new file mode 100644
index 000000000000..73b27a4b5d01
--- /dev/null
+++ b/media-plugins/vdr-admin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+<longdescription>This is a VDR plugin for adminstrative tasks( e.g. network settings )</longdescription>
+
+</pkgmetadata>
diff --git a/media-plugins/vdr-admin/vdr-admin-0.8.0.ebuild b/media-plugins/vdr-admin/vdr-admin-0.8.0.ebuild
new file mode 100644
index 000000000000..0047b8dc3219
--- /dev/null
+++ b/media-plugins/vdr-admin/vdr-admin-0.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: Admin OSD - This is not! the webadmin program called vdradmin"
+HOMEPAGE="http://htpc-forum.de"
+SRC_URI="mirror://vdrfiles/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.3.37"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/admin-${PV}
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -i "s:/etc/vdr/plugins/admin:/usr/share/vdr/admin/bin:" gentoo/admin.conf
+ sed -i "s:/etc/conf.d/vdr.admin.cfg:/usr/lib/vdr/rcscript/plugin-admin.sh:" gentoo/{runvdr,*.sh}
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/admin
+ doins gentoo/admin.conf
+
+ exeinto /usr/share/vdr/admin/bin
+ doexe gentoo/{runvdr,*.sh}
+
+ dodoc gentoo/vdr
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ ewarn
+ ewarn "This plugin is not changed to support gentoo-vdr-scripts."
+ ewarn "So it may not work without large config changes"
+ ewarn
+ ewarn "There are more config Parameter than default are in /etc/conf.d/vdr"
+ ewarn "Find examples in /usr/share/doc/${PF}"
+}